Server stuck in an update loop

22.11.20 04:06:30 (+0100) mc-server --2020-11-22 03:06:30--
22.11.20 04:06:30 (+0100) mc-server Resolving (…,, 2606:4700:3037::ac43:9c26, …
22.11.20 04:06:30 (+0100) mc-server Connecting to (||:443… connected.
22.11.20 04:06:30 (+0100) mc-server ERROR: The certificate of ‘papermc(dot)io’ is not trusted.
22.11.20 04:06:30 (+0100) mc-server ERROR: The certificate of ‘papermc(dot)io’ is not yet activated.
22.11.20 04:06:30 (+0100) mc-server The certificate has not yet been activated

i’m trying to launch my Minecraft Server, which i’ve done a couple dozen times already, yet today for some reason it refuses to cooperate, printing the messages above over and over again. That and the fact that the system time seems to be out of sync. Any help?


It sounds like the time drift is impacting the certificate authorization. You can use chrony tools to try to refresh it (for example, systemctl restart chronyd ; watch chronyc tracking. The balena docs also provide more information on setting (or resetting) time sources.


Hello, thank you for your response!
A moment after i posted in this forum i figured out as well that time will be the problem and began looking into Balena’s documents on how to synchronise it, but as i tried to follow provided solutions i realised that not only do the commands (such as the one that you suggested using) not work, i also couldn’t find track of directiories such as chronyd or ntp. What should i do in this case?

I’m using the dev version of [balenaOS 2.60.1+rev5] on a raspberry pi 4 and i have been entering commands through the mc-server shell under the “services” tab.


The chrony commands would need to be run in the HostOS shell, not the Minecraft service. The main configuration file for chrony is in /etc/chrony.conf.


Everything works now. I haven’t managed to automatically synchronise the time but after fighting for a longer bit i am more than happy to leave my machine in a “it’s working, don’t touch it” state. Thank you for your help.

For those of you in the future who find this topic trying to fix a similar problem, here’s my workaround:

chronyc manual on
chronyc settime Jan 26, 2021 22:50:00

Great. Glad you got it running – and thanks for the tips.