Self_signed_cert_in_chain


#1

Greetings, I am delighted to join this community, the problem that has arisen has been to log me from the client to the server, I get the following:

 _            _
| |__   __ _ | |  ____  _ __    __ _
| '_ \ / _` || | / __ \| '_ \  / _` |
| |_) | (_) || ||  ___/| | | || (_) |
|_.__/ \__,_||_| \____/|_| |_| \__,_|


Logging in to 
? How would you like to login? Credentials
? Email: 
? Password: [hidden]
SELF_SIGNED_CERT_IN_CHAIN: request to failed, reason: self signed certificate in certificate chain

If you need help, don't hesitate in contacting us at:

  GitHub: https://github.com/balena-io/balena-cli/issues/new
  Forums: https://forums.balena.io

the error is it because I am using a free lets encrypt certificate?

I’ve been fighting for several days and I have not managed to get out of here

Thank you very much for your time and excuse my English


#3

Hello, how do you install the Let’s Encrypt certificate? If you’re just starting out, it might be a lot simpler to just go with the ones generated by the quickstart, as discussed in the Getting Started guide.

In any case, are you sure NODE_EXTRA_CA_CERTS exists in the environment when you invoke the command and is pointing to the cert appropriately? Could you please double-check?


#4

Two weeks before installing openBalena, I created a free certificate with certbot, now when installing openBalena, I follow all the steps and the addresses are well pointed to the server. I have checked the variables of and contain the certificate path and it is installed on the client


#5

FIXED:

Solved, sorry for the inconvenience, I think it was because I had a ca.crt certificate from a previous version, I solved it by deleting everything and re-creating the certificate and saving it, thank you very much for your time