RPi writing but not receiving from UART serial

Hi there.

I’ve followed the various directions (e.g. Disable console over Serial in Dev on RPi3? and https://github.com/resin-io-playground/rpi3-uart/blob/master/main.js), and I’m able to receive messages transmitted from the rpi but I’m not able to receive messages to the rpi.

I’ve tried:

  • using screen on both my Mac and the rpi, as well as Coolterm on my Mac
  • changing the baud rate right down to 1200 (default for testing has been 9600)
  • confirming the serial is working with a standard Raspbian disk image (so have ruled out hardware/connection issues)
  • run the test script at https://github.com/resin-io-playground/rpi3-uart/blob/master/main.js (write works fine, but I don’t see any received messages)

(I’ve set the config variables via the fleet options, not locally to the device)

Is there anything specific that might cause the receive not to work while transmitting is ok?

Thanks in advance.

Regards, Grant


the baudrate and other stty settings must exactly match the device you have plugged on serial port.

Thanks Tristan. I have used screen on both systems with the baud rate
manually specified and I’ve also tried the ‘loop back’ method (linking tx
and rd On the rpi) which would ensure this is the case.

As noted, I’ve also confirmed that the exact same settings/setup is working
correctly with the standard raspbian image/sd, so this appears to be
resinos specific.

TIA. Grant

I’ve asked internally about this and we’d like to know what settings you have in config.txt as that governs a lot of the RPi low level behaviours.

Thanks. Didn’t have access to the RPi yesterday, so apologies for the delayed response. The active values below:


I didn’t edit/modify this manually—assuming this is the default and a reflection of the environment setup in the resin.io management UI.

I have also tried to modify cmdline.txt according to these directions:

@grantyoung The default baudrate should be 115200, have you tried testing with this value?