registry unauthorized after certificate update


There are several topic about this error, none of them solved it for me.

I have a fresh install of OpenBalena v3.6.0 on DigitalOcean Droplet Ubuntu 22.04, and I use a Let’s Encrypt certificate.

I know I ran the quickstart script (./scripts/quickstart -U "mail" -P "pass" -d -c) without the -c option once, because I forgot about it. I then ran the quickstart script again, but with the -c, without deleting anything first, and everything worked fine (listing devices, provisionning images, etc).
Only deploying did not work.

What I did to fix it is the following:

  • I ran ./scripts/compose down to stop
  • I deleted the config folder that OpenBalena generates
  • I ran the quickstart script again, making sure to include -c
  • I ran ./scripts/compose build. Not sure this is necessary
  • I ran ./scripts/compose up -d to restart

I suppose the registry was using the old self-signed cert instead of the Let’s Encrypt cert, which caused the issue in my case.
Hope this helps someone !