Raspberry Pi 4 Loses Wi-Fi Connection After MING Stack Deployment


I was deploying the MING stack on my Raspberry Pi 4 (64-bit) and the initial deployment was successful. I used Balena Etcher to flash my SD card. After that, I could see the device online and saw it updating the device over OTA. It took around 30 minutes to download updates and components like Grafana, MQTT, InfluxDB, and Node-RED. Along with those, I noticed another component, Wifi-Connect. When it completed, it started to install, and immediately my device lost the Wi-Fi connection.

I rebooted the device and found it connected to Wi-Fi, displaying “online (VPN only)” in the Balena Cloud dashboard. A few seconds later, my device went offline again.

Hello @Thaha first of all welcome to the balena community!

Today I had the same experience. Disabling the WiFi-Connect container it works and I’m going to explore why is this not running. I will keep you posted!

Thank you @mpous

Could you tell me how to disable WiFi Connect container.

I have connected it via my mobile using wif-connect and entered the same access point and password again. Now it is working…but again issue started.

Any update on this

Hello @Thaha if you don’t need wifi-connect my recommendation is to clone the repository and comment with # the lines related to the wifi-connect service on the docker-compose.yml file.

Then run balena push <your-fleet> and that might work!

I still didn’t find time to research why is this not working! Apologizes!

Thank you @mpous . I will check. However, is there any update on the wifi-connect bug

Thank you @mpous … I pushed the fleet without wifi-connect and now the device is online. However, I have encountered another issue. In the dashboard, it shows that Node-RED, Grafana, MQTT, and InfluxDB are online, but when I tried to open their ports, none of them are accessible. I also tried with the public URL, but I am getting the error: tunneling socket could not be established: 500. One possible reason is that nothing is listening on port 80 on the device. I can run the Node-RED instance manually by opening the terminal on the target device using command node-red

That’s weird @Thaha could you please confirm what device type are you using?

Do you have any logs in the balenaCloud Logs with errors?


I am using Raspberry Pi 4 64 bit with 8mb and MING stack image with HiveMQ.
hivemq4-ming_snappy-river-2024-06-18t14_27_38+04_00.txt (161.5 KB)