Project FIN & Simcom SIM7600E modem

Hey guys,

I have a prototype FIN board running at my office, and the Simcom SIM7100E modem works out of the box.

I am now trying to switch it for a SIM7600E modem due to costs. The modem is recognised by ModemManager but stays in “connecting” state. Any reason why this shouldn’t work?

Gr, Frans

Hey @FransvanHoogstraten - the fact that the modem is recognised by NM means that HW wise, we already validated the support. Now on the software, what base image are you using in your Dockerfile?

FROM resin/%%RESIN_MACHINE_NAME%%-python:2.7-20170719

For raspi3

Can you please try to add the following env var declaration in your Dockerfile, and reboout the device after it has pulled the update?


Yes, I tried it and it does not change the behaviour.

Wouldn’t MM of NM logs help here? How do I get to those again?

These 4 command outputs will be useful for debugging, all of them to be ran from the host (you can access a host shell from your device dashboard):

List all the Modem Manager handled interfaces:

mmcli -L

Show details about main modem (usually it is 0, some modems are enumerated as 1)

mmcli -m 0

Show all the Network Manager profiles loaded (helps understanding if the cellular profile is valid and loaded)

nmcli c

Also, let’s see how the modem is loaded from the USB PoV


mmcli -L output:

Found 1 modems:
        /org/freedesktop/ModemManager1/Modem/0 [SIMCOM INCORPORATED] SIMCOM_SIM7600E-H

mmcli -m 0 output:

/org/freedesktop/ModemManager1/Modem/0 (device id '39b77b6ac448f59e4ccc7e715115c7c95feb29e3')
  Hardware |   manufacturer: 'SIMCOM INCORPORATED'
           |          model: 'SIMCOM_SIM7600E-H'
           |       revision: 'LE11B08SIM7600M22'
           |   H/W revision: 'unknown'
           |      supported: 'gsm-umts, lte'
           |        current: 'gsm-umts, lte'
           |   equipment id: '867584030114974'
  System   |         device: '/sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2'
           |        drivers: 'option1, qmi_wwan'
           |         plugin: 'SimTech'
           |   primary port: 'ttyUSB5'
           |          ports: 'ttyUSB3 (qcdm), wwan0 (net), ttyUSB5 (at), ttyUSB6 (at)'
  Numbers  |           own : 'unknown'
  Status   |           lock: 'none'
           | unlock retries: 'sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 (10)'
           |          state: 'connecting'
           |    power state: 'on'
           |    access tech: 'unknown'
           | signal quality: '60' (cached)
  Modes    |      supported: 'allowed: 2g; preferred: none
           |                  allowed: 3g; preferred: none
           |                  allowed: 2g, 3g; preferred: none
           |                  allowed: 2g, 3g; preferred: 2g
           |                  allowed: 2g, 3g; preferred: 3g
           |                  allowed: 2g, 3g, 4g; preferred: none'
           |        current: 'allowed: any; preferred: none'
  Bands    |      supported: 'unknown'
           |        current: 'unknown'
  IP       |      supported: 'ipv4, ipv6, ipv4v6'
  3GPP     |           imei: '867584030114974'
           |  enabled locks: 'none'
           |    operator id: '20408'
           |  operator name: 'NL KPN KPN'
           |   subscription: 'unknown'
           |   registration: 'home'
           |    EPS UE mode: 'csps-2'
  SIM      |           path: '/org/freedesktop/ModemManager1/SIM/0'

  Bearers  |          paths: '/org/freedesktop/ModemManager1/Bearer/0'

nmcli c output:

KPN                 d811a35a-70fc-3716-84e1-a3578d10cc1e  gsm       ttyUSB5
Wired connection 1  50b16666-4008-3bfd-ab14-0f202999f43c  ethernet  eth0
resin-dns           b38041a6-c11c-4f95-aa2f-0e1673217030  bridge    resin-dns
supervisor0         4768b532-3b27-4fa4-a4cf-bf91aa430332  bridge    supervisor0

lsusb output:

Bus 001 Device 004: ID 1e0e:9001 Qualcomm / Option
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 005: ID 0403:6010 Future Technology Devices International, Ltd FT2232C/D/H Dual UART/FIFO IC
Bus 001 Device 006: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Thanks for helping!

BR, Frans

If you are interested, I can also just give you access to the device…


I upgraded one device to Resin OS 2.13.6+rev1 to test this out. We are facing the same issue with SIM7600E. Device is our custom board based on Raspberry Pi 3 Compute Module. The modem stays in “connecting” mode until it gives this error

Jul 25 10:06:42 8bbc87c NetworkManager[675]: <warn>  [1532513202.5015] modem-broadband[ttyUSB2]: failed to connect modem: Serial command timed out

The device is currently online with an Ethernet connection and is not used for anything else. I granted support access to the device for a week if you want to check this out. Device UUID is 8bbc87c758b7058bc4514ecdf8bf7ec8

Hi @tmn just to clarify, is this an issue you are seeing on the Fin board as well (since we’re in the Fin room)? Or just on your custom carrier board?

Hi Alison,

I have created the topic here because I was seeing it on the FIN board, but now that it is also experienced on custom PCB I think we can rule out hardware issue.

Gr Frans

No solution on my side yet

Hi Alison.

Yes, I tried this on our custom board, so this probably isn’t a hardware issue related to Project Fin. We have a Fin at the office, I’ll test the module with that today to confirm this.

The board we had at the office was actually an older Project Amber board. I couldn’t get the SIM7600E to work at all with that one (the WWAN/WPAN LED’s were flashing continuously and Resin OS didn’t recognize the card). Maybe it’s some kind of powering issue with the older board. A WLAN card is working in that slot, so the slot itself should be fine.

I have an external USB-Mini PCIe adapter board which I can test the card with after I find a suitable power supply for it…

Hi @FransvanHoogstraten and @tmn, I think the core issue is that the sim7600E is currently not supported in master of modemManager (the resinOS connection manager for modems), there is an issue tracking this here: , we are in the process figuring out the best way to patch modemManager to add support, our devices team has the hardware and hopefully will have a way forward in the coming week or two.

Sounds good, thanks guys!

created this PR to get the SIM7600E-H supported by the Balena Fin board:

Also, please make sure you have an antenna connected to the modem, otherwise the modem won’t register with the carrier and it will fail to function as expected.