Problems with balena push

Running command balena push <app_name> --emulated --convert-eol I get the following error:

qemu-arm-static: Unable to reserve 0xffff0000 bytes of virtual address space at 0x1000 (Success) for use as guest address space (check yourvirtual memory ulimit setting, min_mmap_addr or reserve less using -R option)

The command '/bin/sh -c install_packages -y modemmanager bash supervisor gpsd' returned a non-zero code: 1

Hi Can you tell us what version of the balena-cli you are using?

C:\WINDOWS\system32>balena -v
12.38.8

Thanks, we’ll have a look and let you know. Is it an open application that you are pushing, or can you potentially share it with us?

Unfortunately, this application is private and has been used for a long time, but I have never seen such an error. The extreme change in the code cannot be related to the assembly in any way, the changes were only in the application logic itself and were quite insignificant.

In the latest CLI version we updated the QEMU version, which is likely what’s causing this problem. We’ll investigate and get back to you soon.

1 Like

I have pushed using the balena-cli of the following versions v12.35.0…12.37.0, but I always get an error related to qemu-arm-static

My bad for not explaining it well, we also updated the QEMU in our builders, which is probably why you’re getting the error. We’ll investigate further and get back to you as soon as we have more information

1 Like

hey,
i also have problems with balena push on windows cli…

i always got the following error-codes:

[Error] The included balena.yml is not a valid contract, allowed types are sw.application,sw.block,sw.hal-module, stopping build
[Error] Some services failed to build:
[Error] Not deploying release.
[Error] Upstream API server/DB error:
Remote build failed

my container shouldn’t be the problem cause i dont changed anything :slight_smile:

thanks for your help.

BR Bernd

Do you have a balena.yml file at the root of the application? If so, what do you have inside?

yes…

the lines are not touched:

applicationEnvironmentVariables:

  • PORT: 80

my cli also load a update on the first login. now i am on version 12.38.3

Interesting, what’s the reason for using balena.yml in a private application? The reason it’s failing is because we deprecated the old format of the balena.yml, you can find the new format here: Deploy with balena button - Balena Documentation. You can also remove it if you don’t have use for it by the way.

Hi there, we rolled back to a previous version of QEMU, bundled with the cloud builder code. We’ve now rolled back this update while we investigate further. Can you please verify you can (re)build your app(s)?

Thx! Successfully built)

Hey there

Thanks for reporting and confirming.

Cheers

Hey @adolfaka, thanks again for reporting this issue!

Is there a specific reason you use the --emulated flag with the push command? For most arm device types if that flag is not provided it will actually use our dedicated arm builders, which are usually much faster than emulation.

If there is a current reason not to use our arm builders, we would love to know so we can look at improving them!

Hey @adolfaka, is there any additional information you can provide about your emulated docker push process that could help us improve the product? Is there a reason you don’t use the dedicated arm builders?

Hi, @klutchell! Sorry for the long answer, only now I noticed the messages on e-mail. It turned out that there was no need to use the --emulated flag, I misinterpreted the description in the documentation and thought that pushing an application on ARM bases was impossible on AMD64. Many thanks! You saved me a lot of time :tada:

That’s excellent to hear! Thanks for reaching out! :tada: