Pls help- unable to flash SD card because it appears as locked

Apologies in advance if this is an obvious question or has been answered before.

I tried to flash a USB card but I think it is corrupted. Bought a new card and it appears as ‘locked’ in BalenaEtcher. I’m using some GitHub code for a self assembly camera. The original SD card was pre-loaded with the code. I just need to flash my brand new SD card and can’t. As you can probably guess my knowledge of all this is near zero… Thanks !

Hi

  • What etcher version and OS are you using?
  • Do you this behavior on other machines and OS as well?
  • Can you share a screenshot of your Etcher? Not sure what you mean by Etcher is locked - a screenshot of that state would help figure

Thank you, I am using etcher 1.5.116 version and MacBook Catalina 10.15.7. I also tried my son’s PC which also didn’t work- here’s the screen gab with the padlock by the new SD card (I have tried the lock/unlock switches on the card.

(I hope that image uploaded?)

Hi,

By any chance this is a full size SD card with a physical lock enabled on its end (the lock key moved down)? Image show below:
ab4b2a7cb64ec435a4597769cd3d5c72e4bccfd1

Thank you. Yes, tho it’s a mini SD card (with adaptor) that has been switched in the unlock position/ lock position (and increments in between). It still appears ‘locked’ in etcher. It is a new, good quality, SD Card. The original (Pre loaded) SD card appears locked too, on my Mac and on a P.C.
Best wishes

Hi, if the target is seen as read-only by Etcher it means that the OS sees that as read-only for some reason. The part that gets the drive data for macOS is here for example drivelist/list.mm at fcdc5ab0b9eb74579b7ab49e970f0e052e73b7b3 · balena-io-modules/drivelist · GitHub and we then check this value Apple Developer Documentation .
I don’t know why this could be the case just for writing an image, but it seems like either that operation sets the target to read-only or (more likely in my opinion) the card reader/media that you use to plug the card (the adapter, in this case) could have some issues.
I would try with a different reader and adapter, unfortunately there’s not much we can do if the OS sees the target as read-only.

The reason I would check the adapter is because on Windows we do exactly the same (see: drivelist/list.cpp at 260f04f6360a5d4f17cb95fdb60d55d6e6cebbdf · balena-io-modules/drivelist · GitHub ) which means two (very!) different OSes see the same resource as read-only in principle. We just report that information on the UI

Thank you so much, I will try with a new reader/ adaptor and if it doesn’t work I will contact the guy who made it with the information you supplied.

Best

_C