pitft28-resistive touch input problem

I am using WPE and I rotate the screen with 90 degrees. I can set it, no problem. But the touch input doesn’t rotate. Any idea?

Hey there @radu and welcome to the forums.

This will depend on what config variables you are using to rotate the screen, there are some that will rotate the video output but not the touch input. I’ve definitely encountered this before with other displays. How are you doing it currently?

I’d guess that the best way to do it is likely with parameters to the dtoverlay for this display, so something like "pitft28-resistive, rotate=270, speed=25000000, fps=20"(note these are just made up values; change them to the correct ones for your display).

Maybe you’re already doing it this way and it still isn’t working? If so let us know and we can dig into it or make further suggestions! It’d also help to know what screen this is you’re using in case others are using the same and have solved the problem already :+1:

Hey @chrisys,

Thank you very much for trying to help me out. It tried a few days ago the “rotate” setting with no luck. It rotates only the image, not the inputs.

I am using the 2.8’’ 320x240 TFT touch screen resistive for Raspberry Pie from Adafruit

@radu another thing you could try is using the browser block instead of WPE - it’s more up to date.

@chrisys, I was able to run the browser block as suggested. I had to install the fbcp service for the touch screen

So now I see the same image on both HDMI monitor and touch screen.

However, the input touch doesn’t work at all now. Should I install another service?

Hi Radu - I’ve reached out to the maintainer of the FBCP block for some more info. The block is based on the fbcp-ili9341 repo which suggests touch input is not supported. But I’ll see what our maintainer says, since he knows the code much better than me. I’ve a feeling it’s because the DT overlay now hasn’t got touch input enabled - but I’ll report back.

It seems the maintainer is on leave today, so he won’t get back to me until tomorrow at least.

I’ve found an issue on the fbcp-ili9341 repository which seems to back up my understanding: ili9341 + touch · Issue #144 · juj/fbcp-ili9341 · GitHub
Although this issue is for a Pi4, I think the underlying reason (i.e. can’t share the SPI bus) is the same across device types.

Radu - if you go back to using the TFT display without the FBCP block, then you can try adding a device configuration variable to set lcd_rotate=2 which I think rotates the display and touch input.

Hey Radu!

Have you had a chance to try the solution recommended by my teammate yet? Please let us know how we can help.