OpenWebRX software defined radio receiver not working

I have been working through the instructions on this blog here to make a radio reciever.

I have installed the balenas on a raspberry pi 3, logged in via balena CLI and pushed the project (which I downloaded direct from github GitHub - balenalabs-incubator/sdr-spectrum-monitor: Running OpenWebRX on balena to monitor radio spectrum and stream audio.)
I saw the blue ascii unicorn at the end so presumably that went ok.

Back in the dash-board on the balena cloud website I can click in to my raspberry pi and get it’s local ip address but when I try to go to it via a browser with port 8073 I get an error that the site refused to connect.

I have tried enabling a public URL and making a device variable “ORX_WEB_PORT” for port 80 but then I get this error:
We encountered an error when reaching this device:

UUID xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

tunneling socket could not be established: 500

One possible reason is because nothing is listening on port 80 on the device.


To be honest I’m not really sure what I am doing as this is the first time I’ve used Balena.
To check it wasn’t something to do with my network I setup a simple webserver on another computer and checked I could load a web page from a variety of ports including 8073 and that much worked so it must be something I did wrong in Balena. :thinking:

Hi Stephen, welcome to the Forums! Sorry to hear about the troubles, but let’s see what we can do to get you up and running.

First and foremost, if you saw the unicorn, that’s a good sign for sure. In your balena dashboard, is the container in a “Running” status? Also, do you recall if you flashed a 32-bit or a 64-bit version of the balenaOS SD-Card image? You can find that in the balenaCloud dashboard on the device details page, it will either explicitly state that it is 64-bit, or, it won’t say anything…indicating 32-bit. As such:

@alanb128 - Are you aware of any issues with this project by chance?