Omxplayer on raspberry pi4 (64-bit)

Hi all,

I’m having some trouble working out where to get omxplayer for accelerated video playback on the Raspberry Pi 4.

The balenalib images I’ve tried don’t have it and can’t source it for APT.

I tried adding some Raspbian sources but that doesn’t seem to work as they are 32-bit I guess.

Also tried compiling but then I’m missing various libraries which also aren’t available.

Am I missing something obvious?



Hi. Can you try using 32 bits base image?

Is there one? I thought there was only a 32-bit image? Didn’t spot that on balenalib?


You can actually use, for example, any of the Raspberry Pi 3 base images on your Pi4. These will obviously run in 32bit mode rather than 64bit. My assumption is the base images you’ve tried to apt-get install for the player don’t include it because the images they themselves are based upon do not. I’d imagine this is because omxplayer has not been packaged for aarch64 (which is the 64bit architecture used by the Pi4). It’s probably worth just quickly testing with the Pi3 version of the same base image, to see if you can install/run it. If this is then missing in the relative Pi4 image sources, it would tend to support the theory. If you could let us know the base images you’re using, I could also check this for you.

At that point, it probably falls to either asking the maintainers of omxplayer to package it up for aarch64, or compiling it yourself.

Best regards,


Ah thanks @hedss. I thought I’d tried a RPI3 image and it had failed to boot on the RPI4.

Could well have been finger trouble on my part. I’ll try that now and revert.

Hi again,

Definitely let us know if an RPi3 base image of ours doesn’t work on the Pi4, as it should and we’d love to be able to fix it! :slight_smile:

We’ll wait to hear back from you either way.

Best regards,


1 Like

Hi, just to reiterate that we have been referring to base images (the ones you base your docker container upon) and not host OS images. Using whatever base image will not prevent your pi from booting.

1 Like

Gotcha - I think that was the issue.

So with the RPIv4 64-bit host OS image booting from uSD.

I can then use a RPIv3 32-bit OS base image and have all the goodies I need like omxplayer.

That’s all working well here!

Thanks for helping me understand that!