Not supported wheel on this platform Error on TensorFlow1.1.0 Raspberrypi3


Im trying to build a Resin Docker image for RaspberryPi with tensorflow for python 2.7. My base image is arm32v7/ubuntu:16.04 and and I installed python2.7 and pip2.

When the dockerbuild tries to execute these lines it fails:

RUN wget
RUN pip2 install tensorflow-1.1.0-cp27-none-linux_armv7l.whl 

It downloads successfully the wheel but when it tries to execute pip install it says: tensorflow-1.1.0-cp27-none-linux_armv7l.whl is not a supported wheel on this platform

The strange thing is that when I execute the same commands in the terminal (without RUN because it runs on bash) when the RaspberryPi is running RESIN, tensorflow can be installed that way…

Maybe it is how the dockerfile is running in your cloud??? Any ideas?

Thanks in advance

Hey, could you try again using resin/raspberrypi3-python:2.7 for your base image and see if that works - it should help narrow down where the issue could be coming from

Hi, I tried with resin/raspberrypi3-python:2.7 but same error appears, should I post here the entire dockerfile?

Ok, so I tried this out myself and was able to replicate your issue with

FROM resin/raspberrypi3-python:2.7
RUN wget
RUN pip2 install tensorflow-1.1.0-cp27-none-linux_armv7l.whl

when doing git push resin master which will default to native arm builders when it can, I then tried with git push resin master:resin-emulated which forces an emulated build and it seems to be working (albeit very slowly, which is why native builds are the default), so you should be able to git push resin master:resin-emulated as well for the moment. I’ve also filed an issue for this case against the native builders

1 Like

Thanks! It is indeed slow but it works! Thanks a lot!
It would be great if you could add a resin image with tensorfllow raspbian and/or ubuntu base image!

Charlie you need to be able to build tensorflow from sources for maximum speed