Node using GPIO on Raspberry Pi 1 & 2



I am loving Node-RED on a Raspberry Pi. There is also a great package for available BUT it don’t includes GPIO support.
The package python-rpi.gpio or python3-rpi.gpio doesn’t exist in the apt-get repo:

E: Unable to locate package python-rpi.gpio
E: Couldn’t find any package by regex 'python-rpi.gpio’
E: Unable to locate package python3-rpi.gpio
E: Couldn’t find any package by regex ‘python3-rpi.gpio’

So I have succesfully installed RSP.GIP with the pip installer:

apt-get install python-dev python3-dev
apt-get install mercurial
apt-get install python-pip python3-pip
apt-get remove python-rpi.gpio python3-rpi.gpio
pip install hg+

But this don’t fixed the problem with node-red, as you can read here:!msg/node-red/TKct8P6N9lQ/O3JHRrORXtgJ

-The result ist always the same-
A log message from Node-Red:

“[warn] Can’t find Pi RPi.GPIO python library.”

This causes that I can not use the GPIO Nodes.

I am a bit surprised that RPI.GPIO is not already installed in the resin/rpi-node package.
Any idea, how to fix that?

Kindly regards,
vergissberlin (forget berlin)



Can you try and install the .deb package and see if it fixes your problem?

You can take the package from here:

Let me know if it worked.


Hi nchronas!

thank you, for your fast response! This idea even thiseldo has come.

I tried to install it that way Holy cow from Bashdaria! I had a successful deployment with that!

I made a folk, so you can test it here:

regards, André


Hi again,

I’ve just tested it and it works fine, thanks for the repo, I will look more into node red when I have time, It seems very interesting.