No Sound or Microphone Raspberry Pi 4

Hello, I followed this video call tutorial but I do not have audio coming through and the mic is not working. The web camera works when I join the Jitsi meeting but the options show the microphone selections with red icons like it isn’t recognized to use. I have tried changing the selections in the Jitsi menu but there is still no audio or microphone. I do see the 3.5mm plug in the option list. I loaded raspbian on an extra sd card and verified the sound works.

  • Raspberry Pi 4 Model B 2019 Quad Core 64 Bit WiFi Bluetooth
  • TFT LCD Display HDMI Module 800x480 for Raspberry Pi
  • 3.5mm audio jack for sound
  • Mini USB 2.0 Microphone Mic

I have tried setting all of these options with no success:

Right now it is playing a youtube video to attempt to get the sound fixed but I am out of ideas.

I have granted support access

Hi Laura, did you follow the instructions in the project guide to set a Device Service Variable and access your browser settings? Those instructions are under the “Config Mode” section of the blog post you linked.

I don’t see any Device Service Variables set in your device, so I would give those instructions a try, and see if that resolves the issue. Be sure to also follow the instructions to change the Chromium settings. Let us know how you get on!

Hello, I set the Device Service Variables and rebooted the device. I do not see an option in the Chrome settings to set a specific device. It only has options for enabling audio under site settings. Additionally, it worked using Raspbian without selecting any site settings and playing a YouTube video. I cannot find any options in Chrome for a specific device so I’m wondering if that option is gone now?

I selected the audio jack in the Jitsi meeting but still no sound.

The devices all have red exclamation marks next to them. There should only be a few: camera, USB mic, audio jack and a bluetooth keyboard.

Hi Laura.

I think what’s happened here is that Chromium has moved along several versions since I wrote the guide, and balenaDash (which under-pins this guide) has also had some updates. If you can bear with me, I will run the project up again and see if I can replicate your issue - and update the guide where necessary. It may take me a few days, but I’ll get back to you. :slight_smile:

Thanks for the patience.


Great, thank you so much Phil!

Hi Laura,

I’ve run the project up again, and confirmed it’s a combination of changes to Chromium and balenaDash, but I’ve also found that jitsi meet is also different to when I last saw it. It might actually be that it’s too difficult to keep the guide up to date with so many things likely to keep changing - and we may need to retire the blog post.

However, I have got it to work, so let me try and get you up and running. :slight_smile:

Firstly CONFIG_MODE is no longer a supported option on balenaDash, however it only every combined two other settings. If you could set the following as Device Variables or Device Service Variables:


These just allow us to see the Chromium menus and the mouse pointer.

FYI the difference between device and service values is whether they affect all the services, or the service specified - and in this case it doesn’t matter too much. I tend to use Device Service Variables as it means only the specified service restarts when I change the value.

From there, once Jitsi had loaded, it asked me if it could access my camera and microphone, which I allowed:

However the microphone didn’t work, and I got the same yellow warning messages as you. So I went into the Chromium menu (three dots → settings) and found the site settings:

then into the Jitsi specific settings:

where I (again, for some reason) had to allow the microphone:

then I restarted the kiosk service in balenaCloud and Jitsi could access the microphone. I also get lots of microphones but one was already selected. I also get the red exclamation marks, but the microphone works (I had a meeting with myself, there was some feedback and the chat was dull, but it worked).

Let me know if that helps at all.

Thank you Phil! I will try it after vacation and let you know. I attached an HDMI audio extractor for now and have it running just fine.