No Logs on Raspberry Pi 3B+

raspberrypi3

#1

I previously was getting logs consistently back from my Raspberry Pi 3 B+ running the resin node image. All that runs onboard is an express server.

Suddenly I no longer get any logs. If I use strace and attach to the PID of the process, then I can see the logs - but they are not being shown on the balena dashboard for the device. I’ve tried various solutions but nothing works. Any help is appreciated!


#2

Hi freako987

I am getting the same…,

I have 6 devices which have been added in over the last six months all reporting back their logs in realtime…

The 6th device was only added a fortnight ago… and reports fine…

Today I have added a 7th device and on this 7th device all I get in the ‘Logs’ window pane is a message saying:

“No logs yet”

Rebooted and restarted the 7th device… still No logs yet…

Other than that the 7th device is working fully otherwise.

Anyone with any ideas would be much appreciated.

Thank you.


#3

@freako987 -update- I have just updated the 7th device through the balenaCloud interface to the HOST OS VERSION balenaOS 2.29.2+rev2 and SUPERVISOR VERSION 9.0.1

It took around 15 minutes to complete the upgrade and rebooted at the finish…

The device is now showing logs in the ‘Log’ window as per the rest.

Doesn’t actually make any sense as the other 6 devices are running the original older host OS and Supervisor version and they still report home ok…

On this occasion though this update appears to have kicked this unit into life again.

Confused!

09.02.19 21:11:08 (+0000) main Feb 09 21:11:08 dc88858 python[222]: Sleeping for 10
09.02.19 21:11:18 (+0000) main Feb 09 21:11:18 dc88858 python[222]: Showing asset 2.png (image)
09.02.19 21:11:18 (+0000) main Feb 09 21:11:18 dc88858 python[222]: Sleeping for 10
09.02.19 21:11:28 (+0000) main Feb 09 21:11:28 dc88858 python[222]: Showing asset 5.png (image)
09.02.19 21:11:28 (+0000) main Feb 09 21:11:28 dc88858 python[222]: Sleeping for 10


#4

Hi @freako987,

what OS version are you using on your device? Any chance you can enable support access for this device and share a device dashboard link with us?

Thanks,
Robert


#7

Robert,

Thanks for the response! The device is not on on the majority of the time (it controls an LED strip, I hope to post about the project once its finished). I could leave it on for an extended period after enabling support access if that works best.

The board is running Resin OS 2.12.7+rev1.

-Carson


#8

@freako987:
There was a change to the logging subsystem some time ago - updating to the newest image should help here - https://www.balena.io/docs/reference/OS/updates/self-service/ - that would be the easiest fix here. In addition, for paying customers we offer on-device supervisor updates if they cannot update the whole image for some reasons.

@devsterp - how is it going now - do you see logs from every device now ?