Low frame rate on balenaDash RPi4

I am running balenaDash on a rpi4
I am currently getting a frame rate of 13,

I have been told for my project that I should use balenaDash instead of chromium-ha, as it is more stable,

I have tried setting the same chromium flags as the chromium-ha project, however it is still the same frame rate

I also set my GPU to 128 as per Raspberry Pi 4 - gpu acceleration for chromium-browser

Here is my generated /home/chromium/xstart.sh

 #!/bin/bash
xset s off -dpms
chromium-browser --app=https://akirodic.com/p/jellyfish/  --kiosk --start-fullscreen --autoplay-policy=no-user-gesture-required --user-data-dir=/usr/src/app/settings --window-size=1920,1080

Here is my config.txt
disable_overscan=1
framebuffer_width=1080
hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=16
max_framebuffer_height=1920
arm_64bit=1
core_freq=250
dtoverlay=vc4-fkms-v3d
dtparam=i2c_arm=on
dtparam=spi=on
dtparam=audio=on
gpu_mem=192
disable_splash=1
enable_uart=1

Im not sure if I should I should create a new ticket for this, but removing the core_freq var increased the frame rate to 22, which is almost acceptable for my use case, I need the core_freq to be 250 as per the wittyPi3 specifictions, so Is there any way I can increase the graphics performance without changing this?

Hello Patrick, unfortunately there is no way of increasing performance at the moment. The 22 frame rate benchmark is about what we expect for this project on a FullHD (1920x1080) screen. We are actively working on improving this and hope to get much better results in the future.

As a side note, setting core_freq to 250 will effectively under-clock the Pi’s GPU processor, so a performance drop is to be expected. I took a look at the WittyPi3 manual but could not find any references pointing out this core_freq requirement, can you share a bit more on that?

Thanks @tmigone

I am following this thread(WittyPi power management board with a RPi3 docker container) for installation instructions, in the wittys install script ther is the following code

if grep -q ‘core_freq=250’ /boot/config.txt; then
echo ‘Seems the frequency of GPU processor core is set to 250MHz already, skip this step.’
else
echo ‘core_freq=250’ >> /boot/config.txt
fi

I assume its to make their hardware back-compatible with all pi versions

Any ideas if its possible to overcome this or increase the FPS another way?

Hi @PatrickEntabeni, seems like you are following 3 year old instructions to install. My teammate noticed that you might be setting your own Chromium flags rather than using the ones set in the balenaDash kiosk service. Consecutively, you might have missed out the GPU enabling flags:
--ignore-gpu-blacklist --enable-gpu-rasterization --force-gpu-rasterization --gpu-sandbox-failures-fatal=no --enable-native-gpu-memory-buffers
as seen here

If this is indeed the case, you are running without GPU acceleration, hence the low framerate.