Jetson-TX2: Disabling serial console on /dev/ttyS0

My device is a Jetson-TX2 with Cogswell carrier board. I have already compiled an image which dtb files.
/dev/ttyS0 is mapped to RS232 port which we want to use for other purposes and also want to disable serial console (high priority) .

I have commented out the following line,

But it didn’t work and it is still enabled,

    [    0.000000] Kernel command line: console=ttyS0,115200 memtype=0 video=tegrafb no_console_suspend=1 earlycon=uart8250,mmio32,0x03100000 nvdumper_reserved=0x2772e0000 gpt tegraid= tegra_keep_boot_clocks maxcpus=6 boot.slot_suffix= boot.ratchetvalues=0.2.1 androidboot.serialno=0424618090301 bl_prof_dataptr=0x10000@0x277040000 sdhci_tegra.en_boot_part_access=1 root=PARTUUID=5460e71c-46c2-4dba-8d19-1055106a7844 ro rootwait
[    1.823737] console [ttyS0] disabled
[    2.028252] 3100000.serial: ttyS0 at MMIO 0x3100000 (irq = 37, base_baud = 25500000) is a Tegra
[    2.071274] console [ttyS0] enabled

Please let me know how I can disable the console debugger on ttyS0. Thanks!

Hi Balena team,

I am wondering if you can give us any hint or example to help us.


I don’t have TX2 around to test it, but maybe these threads can help: