Inkyshot - nothing showing on display

Inky phat display not changed, either with quote of the day, or a manual message.
This is on a Pi Zero with a fresh Balena OS install.

This could be related to some of the inkyphat issues, where the name badge doesn’t work?
The fix for that one is something along the lines of:
Install smbus2 manually with pip3 install smbus2

python name-badge.py --type "phat" --colour "yellow" --name "Inigo Montoya"  = FAIL
python3 name-badge.py --type "phat" --colour "yellow" --name "Inigo Montoya" = WORKING
python name-badge.py --type "auto" --colour "yellow" --name "Inigo Montoya" = WORKING

Hope someone can help with inkyshot.

Thank you.

Hi,
I assume the device did provision and you can see it online, so can you see any log messages in the dashboard? It should be something like

 main  INFO:root:Display type: InkyPHAT
 main  INFO:root:Display dimensions: W 212 x H 104
 main  INFO:root:Message: Do not be afraid to give up the good for the great.
 main  INFO:root:Font size: 23
 main  INFO:root:Done drawing

and then the display would have changed. I have just tried that and had it work fine with a RPi Zero & Black/White/Yellow Inky pHAT.

Yes, all good like that, just nothing on the inky…
I’m sure it’s something to do with the same issues I have with the default Pimoroni examples.

Thank you.

Hi Richard, would you mind granting us support access and send us the device URL so that we may take a look at the device for you. If you are sure how to do that you can refer to the docs here: https://www.balena.io/docs/learn/manage/support-access/

OK, UUID sent via DM.
Thank you.

Hello again @Richard238, I took a look at the device and everything seems like in working order. I even saw that the scheduled update run fine. Looking at the logs, I don’t see any obvious problem.

To test it out, I manually updated the line you mentioned earlier to: display = InkyPHAT("yellow") in the code running on your device.
Could you please check if this makes a difference? Do you see the “Hello World!” message now?

If you see it, I will push this change to the inkyshot repo and make this color a configuration option. Though I’m not sure if that’d help as I have a Red Inkyphat and it displays the text fine when I set it to to either black or red.

Hi. Sadly not, no change. It’s still showing the default Pimoroni “Hello my name is…”

Richard, let’s take a step back. Can you make sure that your Inky pHat is pushed down firmly?

I wonder if there is a hardware issue as I couldn’t see any software problems so far. I asked my teammates to look further at this device and logs. Can you please extend the support window?
(our access is about to expire)

Support access granted for another 3hrs.

Phat definitely sitting on Pi ok, as I can run the default weather, calendar, name_badge scripts.

Thank you.

@Richard238
Hi Richard, nice to meet you and I’m really glad you’re making Inkyshot - I was one of the project creators. I’m just wondering, could you clarify what code you’ve deployed onto the Pi0? I’m wondering since I don’t recall our code having Pimoroni’s default demo displays and I’m wondering how that showed up.
Thanks,
Catherine

Hi Catherine,

Different SD cards: One for Inkyshot, one for the Pimoroni.

And I’m not the only one with this problem: https://forums.pimoroni.com/t/inky-phat-name-badge-does-nothing/14739/22

Thanks,
Richard.

@Richard238
Thanks for the response - as far as I recall/know of, I don’t think the inkyshot code(https://github.com/balenalabs/inkyshot) and the Pimoroni demos (https://github.com/pimoroni/inky/blob/master/examples/name-badge.py) are compatible in the code we’ve written for Inkyshot.
Did you set up inkyshot with the Deploy with balena button in the GitHub Repo from https://github.com/balenalabs/inkyshot? The inkyshot code doesn’t include running pimoroni’s inky demos as far as I can remember; we only pull from Pimoroni’s python library for the fonts.
@gelbal added a weather feature but that’s on inkyshot, but that is not related to the Pimoroni weather demo.
I’m wondering if this is the issue, let me know if it’s something else though.

No, forget the Pimoroni demo’s, they’re on a different SD card. (But they do prove the hardware works.)

I created my Inkyshot from the Hackster write-up, here: https://www.hackster.io/balena/inkyshot-the-inspirational-e-ink-message-display-c3066b

Ah apologies that I missed that @Richard238. Right that makes sense that the hardware is working then. So you followed the Hackster steps exactly (deploy with balena button, inputted the WiFi credentials, used balenaEtcher and everything) - and nothing happens on the display is what’s going on? (I did the Hackster post as a very quick, less detailed writeup - this writeup goes into more detail with screenshots).
I’m wondering if it has to do with the color variant of the InkypHAT, we might need to ask Chris for his input as I’ve not played with the other ones and don’t know whether it makes a difference with the set up.

Yes, precisely that.

FWIW, Name_badge (Different SD card remember! :wink:) Didn’t work out-of-the-box. My first post in this thread explains the workaround.

1 Like

@Richard238 haha yes ok I’ll give it a run on spare hardware I have later but if we can’t reproduce the error it won’t be helpful :sweat_smile: (except that it could be the yellow variant as I only have the black/white one) My colleagues are saying the logs are showing the software is running perfectly fine so it can’t be that it’s network either :thinking:

I don’t think this issue is caused by colour variants; I have all 3 colours here and all work OK. I’ve just pushed a new release of the latest Inkyshot code to a brand new app (meaning no caching), and everything worked fine. I can only hazard a guess that perhaps there’s some hardware revision that doesn’t work with the old version of the inky Python module?

In that case, the only thing I can suggest to @Richard238 is to bump the versions of all the packages used and go from there. I have prepared a test branch on GitHub that has the latest version of the inky library and associated dependencies here: https://github.com/balenalabs/inkyshot/tree/bump-package-versions

I’ve tested this with my displays here and it works OK. Note to deploy this you’ll have to download it and use the balena CLI to push it as the Deploy with balena button will only push the latest version of the main branch.

Ok, I have downloaded inkyshot-bump-package-versions.zip

What do I do with it to get it on the Pi?
Does the .zip need to be extracted first?

Thank you.

@Richard238 as I mentioned above you’ll have to use the balena CLI to push it. The documentation for this process is here: https://www.balena.io/docs/learn/deploy/deployment/#balena-push and we also have a bit more information here: https://www.balena.io/docs/learn/more/masterclasses/cli-masterclass/#3-pushing-code-to-a-device

To do so you’ll have to extract the .zip file and execute the CLI commands from within the same folder as the Dockerfile for the project after extracting.

I am struggling to see any advantage in the whole Balena project.
Every other Pi project I’ve done worked so much more easily with a bit of sFTP/SSH/VNC work.

Now I have to install balena-cli-v12.25.1-windows-x64-installer.exe and Docker Desktop Installer.exe
How is that any easier?!

I don’t have time to read pages and pages of dull documentation.

With Balena CLI and Docker installed, what on earth do I do next please?

Thank you.