I just can't make my wifi works with balena-sound

I have configured a Raspberry Pi V 1.2 succesfully with Balena sound, but it only works with ethernet. I have tried all the solutions here in the forums but I just can’t make it work. Any other option to alleviate my frustration? Kind regards!


To make sure we are on the same page, while downloading the OS did you enter the wifi credentials? if not what have you tried to add them?

Yes to both. I added them before downloading the OS and double check them in the config files after. I even tried forcing eth0, and other alternative configurations suggested here in the forums. :slight_smile:

Can you clarify the version of your Raspberry Pi?
With Raspberry Pi V 1.2 do you mean Raspberry Pi 1 v1.2?
I’m asking since according to the following list, Raspberry Pi only got embedded WiFi since version 3 Model B:

If you are using an older RPi with an external WiFi adapter, please also clarify the adapter that you are using.
Let me also point you to our documentation page with the list of officially supported WiFi dongles:

Kind regards,

Yes I am using Rpi 1 v.1.2 with an external wifi dongle. The problem is that I don’t know the wifi adapter model to search the compatibility list, but I do know that I was using this dongle before with balena. For an emergency I had to flash the micro sd card, that was previously working with a Balena-sound installation and now is not working anymore. Many thanks for your support!

Hi @dag4rce,

Is there any information on the console, dmesg or kernel log output when you connect or disconnect the USB wifi dongle? That and the output of lsusb -v while the dongle is connected will probably yield some useful information.


Hi! Many thanks again. I am attaching the logs with the suggested console commands. Hope I did it right :grimacing:

dmesg with Dongle.log (18.1 KB) dmesg without Dongle.log (17.8 KB) lsusb with Dongle.log (10.5 KB)


Yep, you did it correctly. :wink:

I can see from your logs that the dongle has been detected:

Bus 001 Device 004: ID 0bda:8176  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x0bda 
  idProduct          0x8176 
  bcdDevice            2.00
  iManufacturer           1 (error)
  iProduct                2 802.11n WLAN Adapter
  iSerial                 3 00e04c000001
  bNumConfigurations      1


[ 2826.812932] usb 1-1.3: new high-speed USB device number 4 using dwc_otg
[ 2826.956356] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8176, bcdDevice= 2.00
[ 2826.965076] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2826.975091] usb 1-1.3: Product: 802.11n WLAN Adapter
[ 2826.982649] usb 1-1.3: SerialNumber: 00e04c000001

but unfortunately the manufacturer string isn’t present in the output - so we’re still no closer to working out what dongle this is.

Please could you run the following command on the host, and send us the output:
nmcli device show

I’m hoping that we’re going to see an eth0 and wlan0 device.


Here it goes!
nmcli device show.log (5.5 KB)

It seems there isn’t a wlan* interface there. Can you enable support access and send me the UUID of your device in a PM maybe so I can take a look. Because this is a weird case.

In general it is possible that the dongle you are using is not supported.

But it was working well last time :sob:


Can you provide us with support access so we can take a look?