Cannot connect to WIFI Balena Sound raspberry pi 3

I have succesfully flashed the raspberry pi3B with balena sound, I have added my wifi credentials in the process. When i power the raspberry pi, i get 4 blinking light followed by a pause, which from looking at the troubleshooting guide tells me there is a wifi connection problem. In the guide it tells me that i need to look if port 443 is open, and whitelist a couple address… So how would i go about to do that?
i havent tried to force eth0, as I could not figure out if I am to add the text to the existing resin-wifi file or to create another file.
Thanks for your help

Hi @quebequer, welcome to the balena forums.

You shouldn’t need to do anything for ethernet to work - just plug it in to any DHCP-providing network (most home routers do this) and it should just leap into life. It’d be good to do this so that we can try and figure out exactly what the issue is with the wifi - is it connected to the wifi network but blocked from accessing necessary resources (as you suggest) or is it simply unable to connect to the wifi network?


Hi, Thanks for your answers.
I got it connected with Ethernet cable. I can see it in the dashboard.
I dont see any services like bluetooth or spotify on the dashboard.
And when I make a scan of the available device, I don’t see it.
What should i do from this point on?

Hi there, if you are not seeing any of the containers running on the device, I have to wonder if your build was successful. Can you try performing the “balena push” steps again, just to confirm the build is successful?

by balena push, you mean to redo the whole process?
Format sd card, download OS, flash sd card and so on?

Do I need to add the services manually for the balena sound project?
(example: bluetooth audio, spotify, …)

Actually, the best and easiest way is to simply click the blue “Deploy with Balena” button located here:

Give that a try, and let it run a fresh build. It will take a short while, but, let’s see if that allows the device to then download the containers.

Yes that is what I did,
With the same results. The device shows up on the dashboard… But it doesn’t show any services running.

I am using rasberry pi 3 B. When I deployed, i selected raspberry pi 3, not the one with 64bit os.

Can you try again, right now? Our builders have had a few isolated issues over the past few days, I’d like to see if a fresh build completes. Thanks!

yes. i do it now.

The new Device has just showed up on the dashboard.

But nothing changed. No services running.

Seems like its not able to download the balenasound application. Let me know what to do from here.
Thanks alot.

Starting here:

Click on the name of the Application, scroll to the bottom, and on the left, click on “Actions”

Click on “Grant support access”

Then I can take a look at it for you.

Alright done. Let me know what you find.

So, it does appear that the build failed. It was attempted 3 days ago. I think the best thing to do is simply delete this App, redeploy a fresh version, download and reflash the SD Card, and start over. You can see the failed build by clicking on “Releases” on the left menu. Starting over is unfortunate, but, the easiest method.


I reflashed the SD, and start over, multiple times to no avail.

I don’t see anything changing…

Its a brand new Pi, so I doubt the problem comes from there…

What do you think?

I couldn’t write you sooner, since I achieve the limited amount of reply for a first time user.


Just an update,
I did the same process selecting raspberry pi 3 using 64bit OS , and it seems to work.

Re Update… So the built has worked, I see all the bluetooth and spotify , airplay app running.
When I play a song connected via bluetooth from either my computers or phone, It will not play out.
Seems like it reaches the pi, but will not play out of the output to the RCA cable. I tried different speakers and cable to no avail. Would that be because I used the raspberry pi as 64bit OS parameter?