I destroyed my Mac with Balena Etcher

I was attempting to write Clonezilla to usb and after the first attempt seemed to produce no bootable drive, I plugged the usb in again, without closing Balena Etcher. I then selected the image and usb drive again (San disk cruzer 8gb). This is when catastrophy unfolded. I remember selecting the Cruzer 10000%, double check the size, no confusion possible with my 500GB 980Pro. I confirm. MacOS prompts me to enter my password. In retrospect maybe this is when warning signals should have occurred to me but coming from Windows and remembering disk utility would also ask for it, I deemed it safe. I see the status bar progressing when suddenly the machine halts into a black screen that reads “no bootable media detected”. Boom. Shock. I just witnessed etcher overwriting my main partition with the Clonezilla image (or at least 30% of it).

How that is even possible I have no idea whatsoever. I have used tools like that countless times in my life never ever had something liked that happened. I’m asking myself, how!? Is it possible that there is fatal bug or am I just plain stupid?

My intel nuc won’t even detect the drive anymore. Using Clonezilla from another machine at least displays the nvme in bios but Clonezilla will immediately exit attempting to copy the main partition with a apfs super block error.

Im bringing this to your attention to please check the application for any possible bugs in this regard. Was I that stupid to copy my main partition?

Hello, I’m not aware of a bug in Etcher that would cause the main partition to be overwritten. Do you recall which version of Etcher you used? Normally the system drive is hidden and has a large red label that warns it is a “system drive”. It also should not let you overwrite the drive where the source file is located. On which drive was your Clonezilla image located? If you’re certain you didn’t choose your main drive as the target, is it possible it failed coincidentally at the same time you were flashing? Can you scan the drive for errors just to confirm?

Hi, thanks so much for reaching out.

I’ve just downloaded the app on saturday so it should be the latest version. I put downloads in a ramdisk so the location should be /Volumes/Tmpdisk/((file)).

First attempt worked but i removed the stick while keeping the app open, test the image and tried to write it again by plugging the cruzer back in, selecting it and writing the image.

It’s a 980 Pro 2 years old I doubt that its a drive failure but who knows. It dd’d fine but like described Clonezilla wouldn’t work as there is a AFS corruption. I assume it wrote 50% of the clonezilla image to the first sectors of the main partition. interestingly, on another machine (because the nuc would no longer recognize it as a nvme drive) opencore is still on it which means I see the OS selector (macos, macos recovery, …) but from there obviously nothing happens (just says No bootable media detected).

Is it possible that opencore has something to do with it?

Hey guys,
Thank you so much for your support. Upon further inspection I discovered that my NUC would no longer recognize any nvme so I opened an RMA with Intel. I received a new machine back today and it turned out that luckily my fear was wrong and that just the nvme had died during flashing (how odd, I know!) After a bit longer than usual MacOS booted fine and repaired itself.

1 Like

Thanks for the update @abcdef and what a coincidence!

glad you got it back working.