How to disable screen with resin-logo.png ?

Hello! I need black background only. How to do this ? Thank you!

hi, I’m not 100% sure if its possible to disable (we don’t have a built in feature for that yet) but the easiest way to do this would be to replace the resin-logo.png in the image boot partition with a solid black .png of the same dimensions.

Thank you. but earlier after boot background was black. And now splash screen not disappeared. Is it bug or feature ? =)

The splash screen will stay on the screen for as long as no one else takes over the access to the framebuffer. So if you have a container that runs a graphical container or something it will take over the framebuffer. There are some cases i have seen where people have something like systemd or xserver installed in the container and it seems to sleep/blank the screen after some time period. But design wise if you boot a balenaOS device with out any container pushed to it, it should keep the splash screen on indefinitely (as far as I understand )

We are playing video, and now i see this splash between video files =( So basically i can’t disable it now =( ? even with RESIN_HOST_CONFIG_disable_splash ?

Oh wait, yes sorry I am an idiot and I forgot that config option was available. Yes I think that should actually do exactly what you want

No, you don’t. Because this option do not helps =(

Interesting, if that option is not working then it sounds like a bug indeed. What balenaOS version and device type are you testing this on, I would like to try reproduce it on my side.

Ah, reading through the raspberry pi config.txt documentation, it seems the disable_splash config is only to disable/enable the rainbow splash seen on the screen, so won’t disable the splash logo.

From https://www.raspberrypi.org/documentation/configuration/config-txt/boot.md

If disable_splash is set to 1, the rainbow splash screen will not be shown on boot. The default value is 0.

ill give that a try

balenaOS 2.43.0+rev1, Rapberry Pi 3

thanks for sharing the version. I have been testing on the OS 2.46 and indeed the disable_splash is only to enable/disable the default raspberry pi rainbow splash screen and doesn’t touch the balena logo splash. We will need to update the documentation and description of that config, so thanks for bringing it to my attention.

To help you solve your issue, can you describe the type of behaviour you are wanting to achieve. What would you expect/like to see as the videos change? There are probably a couple of thing to do, but it depends on the behaviour your want.

I need just black back ground =) Thank you!

okay in that case i think there are two options.
1.) set the resin-logo.png to a pure black image, that way it will always show as a black background.
2.) trigger the plymouth-quit service from your container as soon as it starts. This would need to be done via dbus, something similar to https://www.balena.io/docs/learn/develop/runtime/#checking-if-device-time-is-ntp-synchronized but stopping the plymouth service. You can test this option out by just running plymouth quit from the hostOS and then changing videos.

Hi,
the disabling works fine. Is there any way to deploy the splash screen from within the container?

thanks for your help and best regards

No, the splash screen is part of the host OS and is inaccessible to the applications. That said, it might worth exposing an API for this to be done from inside the container. I’ll make a note for the product team. Thanks!

Hello. I have running devices. And i need to change resin-logo.png on them. I did next:
Entered to device by ssh hten:
mount -ro remount,rw /
rm /resin-boot/splash/resin-logo.png
wget -q http://******/resin-logo.png -O /resin-boot/splash/resin-logo.png

But resin-logo.png still old. How can i fix it on running device ? Thank you!

Hey there! Can you double-check if the file was actually changed? Did any of those commands result in an error?

I found the place where it is: /mnt/boot/splash/resin-logo.png It is works now.

But now i have another problem. White lines.

So what resolution i need, to have black screen on any monitor without white lines. 16:9 (5760x3240) do not works =( I see white lines on right and left.

I need just black screen.

I also found if in /lib/systemd/system/plymouth-start.service
change to ExecStartPost=-/bin/plymouth hide-splash
and reboot
it will works too

Hi there,
the scaling logic is at https://github.com/balena-os/meta-balena/blob/master/meta-balena-common/recipes-core/plymouth/plymouth/resin.script, which can be found in the /usr/share/plymouth/themes/resin/resin.script file in the root filesystem. It sets the background color to white, and then also scales the image and centers it. Unfortunately changing the background color in the script is not possible since it is in the read-only filesystem (can be changed for debugging, but it won’t survive software updates). The only way is to do some tests by looking at the script to understand what the expected resolution is to fill your screen.