How do I Install an older version of chromium?

Chromium seems to have been updated to version 72 and it’s broken my kiosk app. I’d like to revert back to version 65 and not have to deal with this. When I try to install the version can’t be found. Does debian only track the latest packages? How do I install older packages?

Raspi 3B+


FROM balenalib/raspberrypi3-debian:stretch

USER root

RUN apt-get update && apt-get install -y --no-install-recommends \
lsb-release \
nano \
chromium-browser:armhf=65.0.3325.181-0+rpt4 \
caca-utils \
omxplayer \
scrot \
cron \
sed \
xorg \
xinit \
xinput \
xserver-xorg \
xserver-xorg-legacy \
xserver-xorg-input-evdev \
xserver-xorg-input-libinput \
x11-xserver-utils && \
apt-get clean && rm -rf /var/lib/apt/lists/*

RUN sed -i "s|allowed_users=console|allowed_users=anybody|" /etc/X11/Xwrapper.config

RUN groupmod -g 19 input # may differ

RUN groupadd viewer && \
echo ‘notsecure\nnotsecure’ | adduser --home /home/viewer --ingroup viewer viewer && \
usermod -aG tty viewer && \
usermod -aG input viewer

COPY /home/viewer/
COPY /home/viewer/

COPY /home/viewer/
COPY /home/viewer/
COPY /home/viewer/
COPY cron_env_file /home/viewer/cron_env_file

RUN chmod +x /home/viewer/*
RUN chown viewer:viewer /home/viewer/*

# Add crontab file in the cron directory
ADD crontab /etc/cron.d/hello-cron
# Give execution rights on the cron job
RUN chmod 0644 /etc/cron.d/hello-cron
# Apply cron job
RUN crontab /etc/cron.d/hello-cron

# Allow viewer user to start cron daemon with sudo
RUN echo 'viewer ALL=NOPASSWD: /usr/sbin/cron' >>/etc/sudoers

CMD bash -C "/home/viewer/";"bash"

I saw this recently too. I was using a bunch of flags others had posted which were working until recently. I had to remove some or all of '–disable-gpu --disable-software-rasterizer --disable-dev-shm-usage`

Hi @jacobrosenthal. Thanks, unfortunately my app is video heavy and will crash without the –disable-gpu

Hi, I looked around a bit and found this post . It is a bit of work it seems finding your way to the right release but might be worth a try.

Hi @samothx. I actually got v72 working by removing --disable-gpu and increasing memory to 128MB. Thanks for the tip, I’m glad I didn’t have to go down that road though haha