Help - applicationConfigVariables are ignored

From the main code below, please can anyone help to why the applicationConfigVariables are completely ignored.

These contain the required settings that disable BlueTooth and free up GPIO14 and GPIO15 for UART. It also contains the definition for the PPS pin for the GPS module and enables UART, so basically nothing works without these.

I believe the line of concern is:

    - BALENA_HOST_CONFIG_dtoverlay: '"disable-bt","pps-gpio,gpiopin=18,capture_clear"'

Any help is appreciated.

Thank you !

name: gpsTime
description: >-
  Uses attached GPS UART with PPS to provide accurate time via chrony ntp server
fleetcta: Add GPS Modul and stirr well!
joinable: false
type: sw.application
    type: blob.asset
    type: blob.asset
    - BALENA_HOST_CONFIG_dtoverlay: '"disable-bt","pps-gpio,gpiopin=18,capture_clear"'
    - BALENA_HOST_CONFIG_enable_uart: 1
    - BAUD: 9600
    - ALLOW: "all"
    - OFFSET: "0.0"
  defaultDeviceType: raspberrypi4-64
    - fincm3
    - raspberrypi4-64
    - raspberry-pi2
    - raspberrypi3
    - raspberrypi3-64
    - raspberrypi400-64
    - raspberrypicm4-ioboard
version: 1.0.32

Hello, have you tried the concerning line without the single quotes? Also just curious if you have confirmed these configuration variables outside of a balena.yml file, for instance by adding them directly to a device via the dashboard?

Hi @alanb128, thank you for the reply.

I am kind of getting there I think, however still running into issues.

I have addedd the required variables into the Device configuration, however I am not sure the syntax is right as the issues are still persisting.

This is the repo I am using and again have experienced the sames issues as “eagleDiego”. I have tried whats suggested, but again I am not sure the syntax is right for diabling bt etc.

Doesn’t seem to be doing anything · Issue #1 · nmaas87/gpsTime (

Any guidance would be appreciated.

You’re welcome @tissy - It looks like your syntax for BALENA_HOST_CONFIG_dtoverlay might still need some tweaking. Please see Advanced boot settings - Balena Documentation - based on that, your value might need to be "disable-bt","pps-gpio,gpiopin=18,capture_clear" depending on how the parameters are supposed to be grouped.

After much head scratching and spending countless time wondering why it just wasn’t working, i changed the deployment from Dev to Production and bingo, it now works. Not sure what was causing the issue between the two variants, but i’m pleased it is now working. Thank you again @alanb128, your help was much appreciated and provided a good sanity check !