gstreamer Failed to get track duration

Testing BubbleUPNP as a way to play tracks from a music library on Kodi to a balenaSound device. At first, I got nothing but a series of errors from the latter ([ . . . gstreamer] Failed to get track duration) and nothing played. When I enabled Eventing in the BubbleUPNP settings for the balenaSound device as a client, playback started (but without, as expected, any information about actual playback time . . . or any way to stop the track once it had started).

Having disabled Eventing, I’m currently able to play single tracks, but unable to pause them or see anything regarding playback time.

Any settings I should be looking at or for?

Hi @semicha,
It seems you may be hitting this bug which was fixed in v3.5.2.

Could you please let me know what belenaSense version you use?

Hi there, just to clarify, v3.5.2 fixed some bugs however the issue linked above by my colleague is still to be fixed. If you deployed balenaSound recently (as in this past weeks) then you most definitely are hitting the linked bug which is yet to be solved.

Thanks, y’all, that definitely appears to be the issue.

Yes, just deployed a week or so ago; I’ll stay tuned for updates.