Extra Wifi Configuration for JetsonTX2

Hi there!

I have ResinOS running on a Jetson Tx2. I burned the resinOs with specific wifi credentials. The issue is that I want to add extra wifi connections (aka to connect to other networks) but I am not quite sure how to do it. With the RaspberryPi it was straight forward adding some files to the system-connections folder on the SD card. But for the Jetson Resin Image I only found something similar in /flash-rootA/flash-boot/system-connections. I added extra files there but it seems it is not working, aka not connecting to those extra networks I defined there.

Any ideas or how it is supposed to be done with the Jetson ResinOS?

Thanks for the help!

Hi Charlie,

The system-connections folder you are looking for is on the 12th partition of the jetson-tx2 image: resin-boot.

Hi @charlie, besides the other examples here when you provide the wifi connection information at flashing time, you can also access the system’s NetworkManager through dbus, so you can manipulate the settings through appropriate calls within the web-terminal or your application for example.

Here are some examples in the docs: https://docs.resin.io/deployment/network/2.0.0/#changing-the-network-at-runtime

Not sure if the wifi on the TX2 is supported with the resin-wifi-connect project, but we’ll try it out and maybe @majorz can also give some feedback. That would also allow you to set wifi credentials in an even simpler fashion.

WiFi Connect does not support multiple WiFi configurations at the moment. This feature is on the top of the enhancements list and should be available soon though. We provide aarch64 builds and the built-in WiFi chip is BCM4354, so WiFi Connect should be compatible with Jetson TX2, but I have not verified that personally.

Thanks! That worked! For some reason only the 13th and 14th partitions (flash-rootA and flash-rootB ) are being recognized automatically by my Laptop (running ubuntu). I tried on Mac and Windows and I have no access to any partition

I’ll try that and I will give feedback! Thanks!

I got this error at running node /usr/src/app/resin-wifi-connect/src/app.js (I have node v6.11.5)

                self.connection = dbus._dbus.getBus(0);

Error: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
    at Error (native)
    at new module.exports (/usr/src/app/resin-wifi-connect/node_modules/dbus/lib/bus.js:18:32)
    at DBus.getBus (/usr/src/app/resin-wifi-connect/node_modules/dbus/lib/dbus.js:48:12)
    at Object.<anonymous> (/usr/src/app/resin-wifi-connect/src/connman.js:13:14)
    at Object.<anonymous> (/usr/src/app/resin-wifi-connect/src/connman.js:88:4)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/src/app/resin-wifi-connect/src/app.js:9:13)
    at Object.<anonymous> (/usr/src/app/resin-wifi-connect/src/app.js:153:4)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)

Hi Charlie,

I think you need to set the DBUS_SYSTEM_BUS_ADDRESS env var to unix:path=/host/run/dbus/system_bus_socket
like in https://github.com/resin-io/resin-wifi-connect/blob/master/start#L3 .

Thanks, with that the code runs, but it does not create any Acces Point or so.

@charlie, can you please try running the latest version of WiFi Connect (v3). The older Node.js based version of WiFi Connect (v2) is more unstable and most probably the problem you are running into is already solved in v3.