Etcher can't find target

getting the following error when trying to flash a zip file to a sdd (on a mac). Any help would be much appreciated!

Hello, it looks like the only drive available on your computer is the system drive, which Etcher won’t let you flash, as that would render your mac inoperable. Can you provide more details about the zip file you want to flash? Is it an OS image?

Yes, an OS, but I am trying to flash umbrel is into an a sdd on my Mac

https://getumbrel.com/#build

Here is a pic on the hardware I am using

Thanks for the additional information. So you are first clicking “Flash from file” in Etcher and selecting the umbrel zip file from your Mac’s SSD? After that the next step is to “Select Target” in Etcher and choose your card reader with the SD card inserted. We need to figure out why the SD card is not showing up as a target. Do you have another SD card reader or SD card you can try?

I am selecting the umbrel zip from my max and I am trying to flash it to the sd card (to then load into a raspberry pi). But it sees as you say that it’s not detecting the card… I don’t have another reader ir card but will explore that and see if it helps

I’m not familiar with the mac, but perhaps check the documentation for the USB adapter and/or the card reader to see if anything needs to be done for the mac to recognize the card.

Thanks! I tried on a PC and it worked just fine