Enable SPI on UP² Board


I’m trying to enable SPI on UP² board, but I’m facing an issue: read-only file system

After finally managing to dockerize Azure IoT Edge v2 to make in working on Balena (Dockerize IoT Edge v2 for BalenaOS - I’ll update this thread), I’m now trying to install the LoRaWan Stack (github project : https://github.com/Azure/iotedge-lorawan-starterkit/). This makes it possible to have a LoRaWan Gateway running on IoT Edge.

One of the components of this kit (the Packet Forwarder) needs to communicate with the SPI devices on the host machine. To enable SPI, I usually execute this script https://github.com/dcleri/spi-enable to enable SPI on my machine.

In this case, I need to enable SPI since I don’t have SPI devices (i’m running these commands inside the container, not on host OS):

root@5205ab2bd578:/usr/src/app/spi-enable# ls /dev/spi*
ls: cannot access '/dev/spi*': No such file or directory

But when I try to enable SPI with the dcleri/spi-enable script, I have this error:

root@5205ab2bd578:/usr/src/app/spi-enable# ./install_hooks 
mkdir: cannot create directory ‘/lib/firmware/acpi-upgrades’: Read-only file system

How can I enable SPI to have access in the container IoTEdge ?


Hi, we’ll have a look and get back to you.

I just saw this:
https://forums.balena.io/t/enable-spi-ports/ and https://github.com/balena-os/balena-up-board/issues/74

We have some progress on this, we need to discuss about an official way to enable it. So stay tuned, I’ll update once we discuss internally