edge-logic service not starting in the coral-streaming-object-detector

I’ve deployed the GitHub - balena-io-examples/coral-streaming-object-detector and I see it running in my dashboard. However the edge-logic service doesn’t run. It status is shown as Downloaded and there is no log output for this service.

This is my first Balena project. I can SSH into the device. Any suggestions on where to go looking for on device logs?

BTW - I have successfully deployed the Coral audio analysis project, so I know the Coral Dev board & deployment system works OK.

Hi there Kevin,

Could you run the device diagnostics please and let us know of any issues found? Also, feel free to enable support access and someone here can log in and take a look for you.


Hi Phil - I noticed that the model container stops quite quickly after it copies the models. But edge-logic depends on it in docker-compose.yml. I removed the depends_on: from docker-compose.yml and redeployed and it worked. Not sure if this is the correct fix, but it worked for me.

Hey Kevin, I think your workaround is just fine for this case. I’ll ask internally if this is expected when a dependency service stops very quickly after starting, as there may be a race condition here.

Hey Kevin, I got confirmation that this depends_on behaviour is expected and we should not be using it in our example. The problem arises if service A depends on service B but service B exits early, maybe while A is still downloading. Going forward we should avoid using depends_on when the service is expected to exit early.

We’ve opened an issue here for tracking:

Feel free to open a PR to fix it if you’re feeling extra helpful!