Download Error of image on Raspberry pi B



I had created an image that takes suddenly too long to download to Raspberry Pi B.
That image I had successfully built it before and deployed in within normal time period.

I changed only some code in my application without editing Dockerfile.template.

At about 55% i get this error :

Failed to download application ‘…’ due to 'failed to register layer: Untar error on re-exec cmd: fork/exec /proc/self/exe: cannot allocate memory’
Downloading application ‘…’

and the download begins again from the start…

I also pushed some new code to master.
I am using resinOS 2.

Thank you.


I solved the problem putting on the fleet configuration RESIN_SUPERVISOR_DELTA=1.
But I would like to learn why this is happening.


Hey @macvag, which exact resinOS version are you using? The deltas indeed cut down on the image size, there might have been a memory pressure for some images on the less-resourceful Raspberry Pi devices. Using kill-then-download update strategy might also have worked, I guess. :mag_right:

Have you encountered this issue since? If it happens again, we could look at the device and see what’s going on. In general, though, deltas are a better way forward in pretty much all respects (we have a lot of improvements going into deltas recently, both on the backend and on the devices).