Connector and Dashboard Error

Error as follows.

connector balenaBlocks connector version: 1.1.0
connector Changing hostname to c2149d3
connector Generating config
connector Traceback (most recent call last):
connector File “/app/./autowire.py”, line 6, in
connector from pluginbase import PluginBase
connector ModuleNotFoundError: No module named ‘pluginbase’
Service exited ‘connector sha256:dc2e6f5ebf8b5e719415f8a1548ea3d95d4360ab6a4f1f10f6cb2c5f88660e6e’
influxdb [httpd] 172.17.0.3 - - [05/Nov/2021:08:46:03 +0000] “GET /query?db=balena&q=show+field+keys HTTP/1.1” 200 70 “-” “Python-urllib/3.7” cf25aae6-3e14-11ec-800f-0242ac110004 1192
dashboard Interim dashboard sync skipped: No schema found.
influxdb [httpd] 172.17.0.3 - - [05/Nov/2021:08:46:13 +0000] “GET /query?db=balena&q=show+field+keys HTTP/1.1” 200 70 “-” “Python-urllib/3.7” d51e74e8-3e14-11ec-8010-0242ac110004 1289
dashboard Interim dashboard sync skipped: No schema found.
influxdb [httpd] 172.17.0.3 - - [05/Nov/2021:08:46:23 +0000] “GET /query?db=balena&q=show+field+keys HTTP/1.1” 200 70 “-” “Python-urllib/3.7” db172c03-3e14-11ec-8011-0242ac110004 2729
dashboard Interim dashboard sync skipped: No schema found

I’ve waited, rebooted, restarted service. Deleted the device, completely reflashed and redeployed. Not sure where to go from here.

Hi @liquidmayo, welcome to the forums!

Could you tell us more about how did you install balena-sense? Did you use Deploy with Balena or did you clone the repository? Any custom configurations?

Thank you!

I used the deploy button from the project page. No change in variable.

Thanks for that information. What device type are you using for balena-sense?

Raspberry Pi 4.

i do have a pi3 b I could try the same setup path on and see how things turn out. I did successfully have running the old version of this project on a 3b without problems about a year ago.

Hi again,

Thanks for the feedback! It looks like there is indeed an issue with the aarch64 version of the connector block (one of the components of balena-sense). I could replicate the same error just running that package. I’ve created an issue on the connector block repository and we’ll let you know when it’s fixed.

I also tried with raspberry pi 3 (armv7hf architecture) and it look like the block is working there so you should be able to get balena-sense running with that device.

Thanks again for reaching out

Thank you very much for the research and assistance. I will try with the pi3 for my testing for now.

No problem, happy to help. Also I just wanted to let you know the issue has been fixed now in case you want to try with your pi4.

2 Likes

@liquidmayo thanks for reporting this! It turned out that we had a temporary build failure with our base images for raspberry pi 4, specifically the Alpine Python 3 build image. It was still building Python 3.9 whereas the run image was building 3.10. This caused some issues with the block’s multi-layer dockerfile and package caching. I’ve pinned the images both to Python 3.9 now, and all is well with the world again. :slight_smile:

Thanks again,
Phil

1 Like

thank you team for the quick turn around. I have it now running on the pi4 getting data to the dashboard no problem. I am trying to pass data now from multiple devices to a single graph as per the v2 guide, while working with this I did notice this error in the connector

2021-11-09T12:06:50Z E! [inputs.http] Error in plugin: [url=http://sensor:7575]: Get “http://sensor:7575”: dial tcp 172.17.0.6:7575: connect: connection refused

This doesn’t seem to have an effect that I can see on performance of the system. Grafana

I am running with a pi3 and pi4 currently.

Can you share your docker-compose.yml file @liquidmayo ?

No problem, however, I can’t seem to find the location.