Compulab fitlet2 needs which balenaOS image ?

My Compulab fitlet2 has an Intel Intel Atom E3950 Processor.

Which balenaOS image can I use for it ?

Neither Generic_x86_64 nor Intel_NUC worked. Any idea what to do ?

It says:

'root /dev/disk/by-label/flash-rootA' doesn't exist or does not contain a /dev

Hey @skuenstler if neither of those generic images work it might be that specific device support is necessary. This device looks really cool and we’d love to see support for this device added to the platform, so I’d suggest contacting the manufacturer and expressing your desire for them to submit support for balenaOS.

Thanks chrisys, I already asked at their customer portal. No answer so far.

So I think it has more impact if you (Balena and Compulab) interact directly.

Of course I will let you know as soon as I hear from Compulab about this.

Meantime I will also try to deploy by USB-boot (instead of SD-card boot) - but I do not expect a whole lot of a difference…

Good news: I have the Compulab Fitlet2 running with BalenaOS !

The way it worked was to take a USB-stick instead of the SD-card to get the Balena-image installed.

I don’t know why booting from the SD-card did not work. But booting with USB-stick works !

My steps are:

  1. create a BalenaOS device with Architecture Generic x84_64
  2. use Balena Etcher to bring the image on to a USB-stick
  3. connect the USB-Stick to the Compulab Fitlet2 - then power-ON the Compulab Fitlet2
    (4. eventually press F10 and make the BIOS boot from USB-stick if not already per default, eventually boot again having the BIOS settings set correctly)
  4. after booting with the USB-stick, wait and see until the Balena Cloud recognizes the device
1 Like

Thanks for confirming that it worked with a USB-stick and adding the step-by-step @skuenstler