Compose file docker-compose.yml seems not correct

Hi there I try to setup Balena App with TTN and Raspberry Pi to collect and store data.

I have everything setup using this link:

Now the step to push the yml file to the App / or in the PI fails…

Who could let me know wha tis wrong with the file?

I attached the yml file (as a TXT file otherwise unable to uplaod)
docker-compose.txt (674 Bytes)
and a screenshot of the error I get.

1 Like

Hello @chrisvr thanks for your message and welcome to the balena forums!

I downloaded your docker-compose but it looks like you have issues on the identiation of the services. Could you please check it’s similar than this?

version: '2.1'  
        image: balenablocks/connector:raspberrypi3
        restart: always
          io.balena.features.balena-api: '1'
        privileged: true
          - "8080"
        image: influxdb@sha256:b4529fd53e9022bd1e83aaf04c6c6a1ebfffdfa112c31367d69da1354983a24b
        container_name: influxdb
        restart: always
            - 'database:/var/lib/influxdb'
        image: balenablocks/dashboard:raspberrypi3
        restart: always
            - "80"
            - 'dashboard:/data'

Let us know if this works!

Thanks for your quick reply.

What do you mean with ’ you have issues on the identiation of the services ’ ?

What i meant was that connector, influxdb and dashboard services should be under the services and not at the same level (as i see on the txt that you shared).

Aah I see, many thanks. It is processing now to Balena cloud. Really appreciated it. Now I have to work on ’ capturing and storing the data for visualisation

Yes! let us know if that works :slight_smile:

It works. Now following the steps at this url

I need to use HTTP integrations on TTN Gateway Application… but no option anymore for HTTP integrations - see screenshot.


y updated manual from you end?

Did you try to use Webhooks and then Custom webhook?

I will update the documentation!

Yes I tried but need more specific info I think form your end like:
webhook format
base url
downlink api key
and some others (see screenshot)

Hello @chrisvr my cubecell was not working! Testing now and updating the docs on our side :slight_smile:

i will keep you updated!

Allright @chrisvr finally it worked on my side!

First of all you need a decoder function that should run on your End Device section.

Then go to Integrations > WebHooks and then Custom Webhook

Check the Uplink message checkbox! and that should work!

Let me know if that worked for you!

Hello @chrisvr I’m writing to you again to see if you could configure properly your LoRa node on The Things Stack.

We also updated the blogpost here Build a solar-powered weather station with LoRa & The Things Network