check sums do not match on flash

Hello everybody, So im starting to get very frustrated with etcher, I have used etcher before about 2 weeks ago when flashing kali-pi4 on my mircosd. Everything worked fine till now, Last night i wanted to re flash Kali on my RPI-4 and nothing, ive been trying to figure out whats going on for the past 5 hours… So ive downloaded different images like raspbian, sticky fingers, Kali pi and nothing seems to work, so i went to bestbuy right now picked up a brand new SD card in hopes that would work annnnnnd nothing. tried to switch USB ports and now a new SD card… for some reason it says it flashes onto the SD card but then tells me 1 Device failed and physical device drive3: source and destination checksums do not match… if somebody could get back to me please that would be great!

Alright guys, So i went to my friends to use his computer and everything flashed fine? any ideas?

Hi, can you tell us more about your setup?

Which etcher version did you use?
Which SD card?
Did you use the same version of etcher and the same SD card at your friend’s place?

Hello, I tried it again today and the the same thing.
Im currently on windows 10
im currently using version 1.5.81
I currently have 2 SD cards a samsung and SANDISK
and yes same sd card and version.
thank you!

Can you share the logs from Etcher?
You can open the developer tools window using ctrl+shift+i when Etcher is open and then select the console. Do this right after starting etcher, and then share the logs that you get there here so that our developers can take a closer look

One other thing that you can try is follow the instructions on this superuser forum -

What happens is that after writing and before verifying the image on the disk, Windows opens the newly created drive and adds some files. This can cause the checksums to mismatch