can't fetch raspberrypi repository

Hi all,

I’m trying to build the rasberrypi image but I’m having troubles fetching the submodules, here are the logs of the CI pipeline:

Getting source from Git repository
00:06
Fetching changes with git depth set to 50...
Reinitialized existing Git repository in /builds/1DyvR8Cc/0/lb/iot/build_environments/edgedevices/raspberrypi4-64/.git/
Checking out b47f853e as devel...
Updating/initializing submodules recursively with git depth set to 50...
Synchronizing submodule url for 'balena-raspberrypi'
Synchronizing submodule url for 'balena-raspberrypi/balena-yocto-scripts'
Synchronizing submodule url for 'balena-raspberrypi/layers/meta-balena'
Synchronizing submodule url for 'balena-raspberrypi/layers/meta-openembedded'
Synchronizing submodule url for 'balena-raspberrypi/layers/meta-raspberrypi'
Synchronizing submodule url for 'balena-raspberrypi/layers/meta-rust'
Synchronizing submodule url for 'balena-raspberrypi/layers/poky'
Synchronizing submodule url for 'balena-raspberrypi/tests/autohat'
Entering 'balena-raspberrypi'
Entering 'balena-raspberrypi/balena-yocto-scripts'
Entering 'balena-raspberrypi/layers/meta-balena'
Entering 'balena-raspberrypi/layers/meta-openembedded'
Entering 'balena-raspberrypi/layers/meta-raspberrypi'
Entering 'balena-raspberrypi/layers/meta-rust'
Entering 'balena-raspberrypi/layers/poky'
Entering 'balena-raspberrypi/tests/autohat'
Entering 'balena-raspberrypi'
HEAD is now at 366c77e v2.83.10+rev1
Entering 'balena-raspberrypi/balena-yocto-scripts'
HEAD is now at 4bfb805 v1.14.9
Entering 'balena-raspberrypi/layers/meta-balena'
HEAD is now at c9f3bda v2.83.10
Entering 'balena-raspberrypi/layers/meta-openembedded'
HEAD is now at c38d2a74 dnsmasq: Add fixes for CVEs reported for dnsmasq
Entering 'balena-raspberrypi/layers/meta-raspberrypi'
HEAD is now at a6fa6b3 raspberrypi4: Use full kms (vc4-kms-v3d) DT overlay
Entering 'balena-raspberrypi/layers/meta-rust'
HEAD is now at 448047c Upgrade to 1.54.0 (#359)
Entering 'balena-raspberrypi/layers/poky'
HEAD is now at 29b3fe8 harfbuzz: upgrade 2.8.2 -> 2.9.0
Entering 'balena-raspberrypi/tests/autohat'
HEAD is now at 0973697 v0.2.0
error: Server does not allow request for unadvertised object f0c75016f06c0395d1e76fde0ef1beb71eaf404a
Fetched in submodule path 'balena-raspberrypi/layers/meta-raspberrypi', but it did not contain f0c75016f06c0395d1e76fde0ef1beb71eaf404a. Direct fetching of that commit failed.
Failed to recurse into submodule path 'balena-raspberrypi'
Cleaning up file based variables
00:00
ERROR: Job failed: exit code 1

Any suggestion on this? Thanks