Can't add new device using balena dashboard

Whenever I try to add a new device resp. download the image I get redirected to https://api.balena-cloud.com/download but receive following message: “At least one of the deviceType or appId parameters must be specified”.

Haven’t added new devices since a few weeks but have successfully generated images before.
Anyone else seeing this? And is there something I can do about? As far as I know I can’t generate / download images using the cli client, right?

The issue happens in Crome on Mac os big sur, Chrome Version 105.0.5195.102 (x86_64).
Firefox 105.0b5 is not affected and images can be downloaded successfully.

I just tried on macOS Big Sur, Chrome Version 105.0.5195.125 (x86_64) and couldn’t reproduce this. I tried a RPi2 fleet and a balenaFin fleet, and both ESR and non-ESR OS’s. If you’re able to provide support access to the Fleet you’re experiencing this with, a support agent might be able to get to the bottom of what’s happening. But the different in behaviour between browsers is strange. I don’t suppose you have a plugin installed on Chrome that might be affecting parameters sent to a redirect?

On the cli question, the answer is yes, you can use it to download images. Try entering balena help os download to see the options. You can also configure the image it after downloading so, for example, it is specific to your Fleet. See balena help os configure for details.