cannot receive udp packets from multicast address

I have a container running a c# script that sends and receives UDP packets on port 5353. but for some reason I can’t receive any UDP packets. I double checked the rules and even added some extra rules to allow that port. The listener basically listens for UDP packets coming from a multicast address ( and every couple of seconds a message is sent to the multicast address using the same port (5353).

in Wireshark i can clearly see that the messages are sent succesfully, but i just receive nothing, as in literally nothing (no errors, just nothing).

Any help is apreciated, I have a very limited knowledge of linux and zero knowledge of Balena

I realize this was a while ago, but I ran into the same issue. In my code I opened a listening socket for the network adapter’s IP Address. That worked fine in Windows, but in Linux that meant multicast messages were filtered out. I had to open a listening socket for IPAddress.Any. Hopefully this will help somebody.