Cannot connect to WIFI Balena Sound raspberry pi 3

Here is what i do.
I deleted the existing application, and format my SD card.
Then I create a new application inserting the balena-sound for raspberry pi 3.
Then I add a device choosing Development and ethernet and wifi.
I enter my credential for the network.
I download the file then flash it with etcher.
When I connect my raspberry pi inserting the SD card and an ethernet cable, it shows in the dashboard but will not download anything.
I looked in release and there is nothing showing up.

I do not see where you can select “Use an existing application instead”.
Thanks for your help



I am having the same issue with Raspberry Pi and cannot get any sound to come out of my 3.5mm jack. Can you assist? I am using the following:
balenaOS 2.38.0 rev+1
Raspberry Pi 3 using 64 bit OS
my Define DT parameters are set to “audio-on”


Take a look here (scroll down to No audio when using balenaOS 64 bit on Raspberry Pi 3's)

Hi, Thanks I am not using multi-room (I only have one device on your balenaSound fleet) but cannot disable it bc the link is broken.

Hi TaliseG, can you take a screenshot of that please? I’m not entirely sure what you mean by the link is broken? Are you referring to ? (That page does load for me).

Under first bullet point the link listed for: “Check our docs…” doesn’t work for me.

Great catch! We will get that updated.

In the meantime, the correct way to do is to add an Envrionment Variable called SOUND_MODE and give it a value of STANDALONE. That is documented here:

Thanks for pointing out that documentation error, though!

Looking back at your issue closer - I think this is potentially a bug that we are currently chasing down on the Pi 4, which perhaps is now a part of the Pi 3 kernel as well: Audio goes through HDMI instead of AUX cable.. I will ping our balenaSound maintainers to have a look. Thanks!

That worked thanks! One last question. I don’t have any Environment Services listed should I add them for the following:
SOUND_DEVICE_NAME / BLUETOOTH_DEVICE_NAME (value = any valid string)


Yep - go ahead and add the AUDIO_OUTPUT variable and set it to RPI_HEADPHONES to see if that then resolves the 3.5mm jack issue. Thanks!

Hmm not yet. I see that the device is connected and discoverable on my laptop but no sound yet. What do you think it could be?

Well, that may very well be the result of the bug I am referring to, that we are still investigating in Audio goes through HDMI instead of AUX cable..

With that said, is there any chance you can test an HDMI audio device, just to see if the sound is actually coming through there?

I can but should I add a new Environment Variable of AUDIO_OUTPUT with value = RPI_HDMI0 and delete the the old Environment Variable of RPI_HEADPHONES?

For testing purposes at the moment, I would say leave it alone. The setting that you have, RPI_HEADPHONES is supposed to be forcing output to the Aux port, but clearly that is not working, so I’d like to have you test if it is inadvertently sending audio out via HDMI instead.

I found a workaround that made me able to hear the output. I deployed the balenaSound application
initially by installing the CLI and pushed it BUT my services were not listed. I changed the variables but it didn’t work. I found another forum entry that said to use the “Deploy with Balena” button (located on this page: ) which worked. I just need to now work on playing music via the 3.5mm jack which I assume can be done with a new variable.

Prior forum post that was helpful here: balenaSound no services on raspberry pi 3b

I used the same button too. Is there any new update?

I deployed it 4 days ago.

Hello Jose, Please could you describe the problem you are having (It might be best to do this in a new thread as it seems there are multiple issues already on this one).

I deployed it on Saturday, November 14 and it worked. I am not sure if it has a new update. Best of luck.