Cannot change resolution on Jetson TX2

It seems xrandr can detect only on resolution for min, current and max resolution. Here are the output of xrandr for two different monitors,

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 480, current 800 x 480, maximum 800 x 480
default connected 800x480+0+0 0mm x 0mm
   800x480       66.00*

another monitor,

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 600, current 1024 x 600, maximum 1024 x 600
default connected 1024x600+0+0 0mm x 0mm

and this the output of xrandr of the last monitor on my desktop computer,

DVI-0 connected 1440x900+3840+0 (normal left inverted right x axis y axis) 697mm x 392mm
   1024x600      60.08 +
   1920x1080     60.00    50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1280x1024     75.02  
   1440x900      74.98*   59.90  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    72.81    60.00    59.94  
   720x400       70.08

How can I get all options for resolution?


@Farzad Does it help if you specify a specific output in the call to xrandr?

I followed these posts instruction and it didn’t work.

It is fixed !
Jordan pointed out that it was a default framebuffer resolution rather than using the TX2’s GPU and it didn’t have Nvidia drivers.

The Dockerfile needs the driver packages,

the script doesn’t update system cache with tegra shared libraries so update system cache with /usr/lib/aarch64-linux-gnu/tegra/.

:pray: thanks !