Can not hide hotspot created with system-connections file

#1

Good day,

We seem to be unable to create a hotspot that has a hidden SSID on our raspberry pi.
We added the the file /mnt/boot/system-connections/shared-hotspot:

[connection]
id=shared-hotspot
type=wifi
autoconnect=false
interface-name=wlan0
permissions=
secondaries=
autoconnect-priority=50

[wifi]
band=bg
mac-address-blacklist=
mac-address-randomization=0
hidden=true
mode=ap
seen-bssids=
ssid=SomeRandomSSID

[wifi-security]
group=
key-mgmt=wpa-psk
pairwise=
proto=rsn
psk=TotallySecurePSK

[ipv4]
dns-search=
method=shared
route-metric=500

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

After which we rebooted our device and after starting the connection as well as inspected it with:

nmcli c up shared-hotspot
nmcli c show shared-hotspot

It correctly displays:

802-11-wireless.hidden:                 yes

But we can still find this hotspot with our phones.
I consulted the documentation at https://developer.gnome.org/NetworkManager/stable/nm-settings.html to verify that the hidden setting should indeed make the network manager not broadcast its SSID when mode is set to ap. So I am assuming this is a bug?

The device in question is:
Model: Raspberry Pi 3B+
Host OS Version: Resin OS 2.15.1+rev2
Supervisor Version: 7.16.6
nmcli --version: nmcli tool, version 1.12.2

Greetings, Tarek

0 Likes