Build servers report unavailable connections

Good day,

The balenaCloud status shows all systems as operational, but I’m getting
grpc: the connection is unavailable
error messages and general timeouts when building via the balena CLI.
Log attached. Around line 80-100 the grpc errors occur.

build.log (8.1 KB)

Something wrong with the build servers?

Greetings, Tarek

1 Like

Hi, we are checking it out.

1 Like

Could’ve been a short temporary thing, it is working by now :confused:
EDIT: love the pumpkin :smiley: and thanks for your quick response though!

1 Like

Notified our team, though, as we don’t like issues left unchecked, and forcing you to rebuild…

1 Like

Specifically it’s happening on arm01 build server.

The exact error is grpc: the connection is unavailable

Builds work fine on arm02. It’s been happening for the last 12 hours or so.

My log shows running it on arm02 and failing, though.
But on the contrary it worked on arm02 aswell a few minutes ago, so doesn’t seem to be entirely dependent on the build server?

I am having the same issue. @imrehg anything else you need from us to debug it? I’ve tried pushing my code 4 times in the last 20 minutes and all fail with

[main]     grpc: the connection is unavailable
[Info]     Uploading images
[Success]  Successfully uploaded images
[Error]    Some services failed to build:
[Error]      Service: main
[Error]        Error: grpc: the connection is unavailable
[Error]    Not deploying release.
remote: error: hook declined to update refs/heads/master
 ! [remote rejected] master -> master (hook declined)
error: failed to push some refs to ''

Checking with our team again.

Hi, this sholud be fixed now. Do you still hit this error?

Yes it worked since quite some time again, not hitting this error anymore. Thanks :slight_smile: