balenaOS unable to connect to api.openbalena even after setting dnsServer in config.json


I’m trying to connect a Jetson Nano device to my openBalena (v 2.0.3) server.

I’ve asked a similar question where it was suggested I edit the /etc/hosts on device with relevant information.

Since the issue was with name server resolution, I’ve setup a DNS Server using dnsmasq and have set all the addresses to point to my openBalena server. I’ve verified that the DNS server is working by doing nslookup <apiUrl> <dnsServer>. I’ve configured a Jetson Nano balenaOS image (version v2.47.3+rev3 developement) using the config with dnsServers.

Even after doing all this, resin_supervisor is unable to connect to my <apiUrl> and the device is not showing up on balena devices.

Is there some version/config that I’m missing? Please help me understand how to setup custom dnsServers in the config so that the OS can connect to openBalena server


Hi. What is your set up? From the thread you linked, it seems you’re using openbalena.local as the domain name for the openBalena instance, correct? Is the Jetson Nano in the same local network as the openBalena instance?

Now, I’ve moved my openBalena server to a remote instance and my Jetson Nano is not on the same network as the openBalena server.

While doing balena os configure, I gave a config file with my DNS server information; which is able to resolve the CNAMEs properly. I also checked systemctl status dnsmasq and see my DNS information present there. But resin_supervisor is still not able to resolve CNAMEs properly

Hi @abmg. I’ve found this answer from my colleague that seems to be very relevant to your question How to setup CNAME .
You mention that resin_supervisor is still not able to resolve CNAMEs properly. Do you get any particular error? How did you conclude that there is an issue with the resin_supervisor?