balenaOS on odroid XU4 is DOA


I’m trying to use balena on my odroid XU4. I followed the steps here:

When it came time to actually boot the odroid, the fan spins a little, the “ALIVE” LED flashes for like a microsecond, and then it all stops and just hangs there.

I verified my odroid actually works by burning a different OS (used etcher and everything to make the SD card), and it actually booted. I additionally tried using the balena CLI to download older versions of balena OS and none worked.

So this would seem to be a problem with balenaOS.

Any ideas / help?


Hi, can you please try the steps for enabling a device through our cloud dashboard:
It will be easier to set it up through the dashboard since you won’t have to configure the image with the CLI, but may use a preconfigured one.
Please let us know if that fixes it for you.

Hey this has actually been working the whole time. I plugged into HDMI and saw an actual log of the device booting and turns out the fan / LED was shutting off even though balena had booted.

Facepalming pretty hard right now.

Thanks for the help!

Cool :slight_smile: no worries