BalenaOS and Homeassisant - Can't get usb Zigbee radio pen to show

Hi, is this a 4GB RPI4? Just occurred to me this might be relevant.

Let me check whether this patch is applied in our kernels.

I will do it.

Just to let you know:

I made a clean install with just Homeassitant, without the balenaOS, just the sdcard with the homeassistant app.

I plugged the pen and it worked immediately, it even paired with my zigbee devices.

it is a RPI4 8GB, the second element of the fleet is a RPI4 2GB

Hi, I think this might be related:

But if you are using 2.67.3+rev4 the fix should already be included.

We will try to reproduce this internally and let you know.

One more thing. Could you please paste the output of lsusb -t for the 2GB RPI4? I would expect this one should detect both ports.

I got this

   root@b1c2c90:~# lsusb -t 
    /:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M
        |__ Port 1: Dev 2, If 0, Class=, Driver=hub/4p, 480M
            |__ Port 3: Dev 3, If 0, Class=, Driver=cdc_acm, 12M
            |__ Port 3: Dev 3, If 1, Class=, Driver=cdc_acm, 12M

I tried the Zigbee Pen on the 2GB and it worked.
At this momment, I will do a clean install in both and try again.

I had the 2.51v because I had a issue with sound comming from HDMI, but I have the information that is no longer an issue. Let me try.

Hello there,

Thanks for that output. It shows the expected values. I also did a fresh installation of balenaOS 2.67.3+rev4 on my RPi4 (8GB) just now and I could see all of the USB ports fine.

So please let us know how it goes with RPi4 and the latest balenaOS.

Hi gelbal, can you please confirm if the HDMI sound output is working?

Hey @MistformUltimus, I just had the chance to look at this thread now. I see that we identified the issue with HDMI on this other thread:

It’d be great to keep the threads focused on the specific issues. So coming back to the original issue in this this thread with USB ports: Do you still experience issues?

Let us know how it went with your final test at the end.

Hi gelbal,

For what i know and for what i’ve been testing i cant have the sound from the hdmi and the usb port working for some reason…

So in version 2.50.1+rev1, like chrisys said, the sound from hdmi works, but the usb doesnt. On the 2.65 the usb works and the hdmi sound is not working.

So i would like to keep both : Sound from HDMI and the USB port working with the zigbee pen.
Do you have any alternative to make both work in some BalenaOS version?

Hi Alex, I just replied to you over at hdmi-output: not working in RPi4 · Issue #79 · balenalabs/balena-sound · GitHub. For others wanting an in depth explanation please refer to that GitHub issue for details.

The TL;DR is that the Pi Foundation changed the way the audio hardware on the Pi works in version 5.4 of the linux kernel. This changes were added into balenaOS (only for Pi4) on version 2.54.3+rev1. HDMI audio output won’t work by default now, you’ll need to select the interface as your desired audio output. To do that if you are using balenaSound (or the audio block for another project) you can use the environment variable AUDIO_OUTPUT and set it to RPI_HDMI0. This is described in detail in the balenaSound docs and the audio block readme.

In your case Alex, I would go back to 2.67 which is the latest and greatest, has usb zigbee working and set the env var so you can also enjoy HDMI audio. You don’t need to change hdmi_force_edid_audio, hdmi_mode or any other config.txt variable. If you have please revert the changes, the defaults should work fine.

Hi tmigone,

Thank you for your time! I already updated my pi to the latest and made that chance in the environment settings and now it is working as intented.

thank you so much.

Nice. Good to hear that it works fine now. Enjoy : )