BalenaFin cannot connect Internet via 4G modem setting

Hi, I currently want to achieve internet connection via 4G data card. I followed instructions from here:

I modified the existing resin-wifi wile as .ignore file and created a new cellular file. However, it seems like my balenafin didn’t process it well. Even I remove the data card from board, the fin is still connected to my balena cloud. Therefore, it still connects with my WIFI.

Hi there,
It’s a bit odd that you’ve created the file int the /resin-boot/system-connections directory as described and it doesn’t work. Could you please create a new .img file from scratch and try again. I’d like to make sure that there are no left characters around that could block the setup.
In case it still doesn’t work could you please share the cellular file with us to take a look?

@georgiats Sure, I will give a try. Just wondering that if I have already burned the image to my fin, can I just simply change the resin wifi file to cellular by just connecting it with my laptop? Or do I need to re-process it from the beginning starting downloading a new image?

That’s a good question.
You definitely don’t need to reflash your device. Here is an answer from one of my colleagues on how to disable the wifi-connect using the network manager CLI. It’s possible that adding that resin-wifi wile as .ignore file didn’t do the trick.

@georgiats Hi, I tried with uploading a new image and still not working. My cellular file looks like below. Meanwhile, I also set the wifi file to .ignore file.


Then I checked with NetworkManager CLI:

So, it seems like it contains both gsm setting and resin-wifi. So, how could I disable the wifi first and turn on gsm, but then I need to turn on wifi again and switch off gsm.

Hello, to disable wifi you can try

nmcli radio wifi off

which will turn of the WiFi from the fin. Before you turn off the WiFi connection, make sure you have other ways of accessing the device, as you have with 4G, or you will lose remote access to the device.

Let me know if this works for you.

Hi @mpous That.s what I am worry about. I cannot know if the 4G works when I switch off the wifi on fin. But if doesn’t work, how can I access to the terminal window

Hi Tony

  • You can access the terminal window in a couple of ways - the easiest is through the balena dashboard since your device seems to connect to balenaCloud. If you want to do this locally, you can flash the development image and connect to the device using a serial cable.
  • When you say you edited the file, what was that path of the file you edited? And how did you edit it - was it by connecting the device to your computer using a USB cable?

@anujdeshpande Hi, yes. I edited by connecting the fin via a USB cable to laptop. I created the cellular file and set the resin-wifi file to .ignore file.

So, if I switch off wifi by nmcli radio wifi off, will the gsm automatically be set to use?

Hi Tony,
Let’s try to make sure first that the 4G data connection works properly so that we know how to proceed.
Could you please

  1. remove the wifi file from the .ignore file
  2. make sure that the wifi connection now works
  3. run nmcli radio wifi off and see if you automatically connect to your 4G network. _The expected behavior is that it will connect to the gsm automatically, given that the cellular file contains the right info. _

Once we know this works we can move on and assist with further troubleshooting.

@georgiats So, I ran the nmcli radio wifi off, and the fin status shows that it is online but with no vpn connected
And currently I cannot open the Terminal window on balena cloud to switch on the wifi getting remote access. The sim card works properly for internet connection since I tested within my phone.

I am using Quectel EC25 modem just in case.


  • The Quectel EC25 is something that we use with the fin in our GPS tracker project as well, so that should be okay.
  • Can you enable support access for the device, and send the device’s UUID to me as a private message?
  • One thing that will help is to look at the dmesg logs as well as Network and Modem manager logs from /var/log/journal. Enabling persistent logging would also help - that way we can reboot the device and still have logs from the previous boot on the disk.
  • If it shows online, but no VPN it might be the case that only the API is able to connect. Do you still see the logs then? Not being able to open a terminal is expected if the VPN isn’t working (see more about our device states here

Sure, I PMed to you within detail


Thanks for sharing device access. Can you power cycle the device?

Sure, it is powered now


  • It looks like the device wasn’t configured correctly for the SIM. I see that it has received just one IP - the local one from WiFi.
  • I would normally ask you to connect to the device using a serial cable, but it looks like the device is using a production image and not a development one.
  • In that case, can you reflash the device with your WiFi credentials included? You can do this by downloading the image from your app in balenaCloud

@anujdeshpande I re flashed again and PMed to you. And it seems like the gsm is prepared to connect, however, when I switched off the wifi, it is not connected.


Thanks for sharing access. I am taking a look now.

After flashing the device, did you make any changes?

@anujdeshpande Hi, I only added a same cellular file like before with no other operations