Balenaetcher seperated 5TB HD into Two Disk; How to Fix to make one drive again

Good Morning. I used a 5th WD harddrive to flash Batocera using BalenaEtcher and it created a Disk 0 w 931 GBs and a Disk 2 with 4657 GBs. I want to combine these two back into a 5tb hard drive but it will not let me. I tried using the command prompt with diskpart and it doesn’t combine the two disk back together again. I have tried third part partioning programs and nothing. I have hit a wall. It;s not like it partioned the 5tb hard drive, it made two different disk. I have read the post about “balenetcher broke my drive” and that solution did not fix the problem. Please help. Thank you.

Hi, would you be able to provide a bit more information:

  1. what OS and what version of etcher are you using?
  2. how did you connect the harddrive to your computer?

In general the way to install Batocera to HD is to create a bootable disk and then install the OS to hd. from the usb booted system.

I am using Windows 11. The verison of Balenaetcher is the latest version.

I comtected the 5TB hard drive with a usb. It is WD Hard drive.

I think thats what it did. Its created a disk for the OS and a disk (Disk 0) for everything else (Disk 2). What i want to do is combine both again into one disk. If it partioned the disk and kept it on the same disk ie Disk 0, that would be great because i could format both partitions abd merge the drives back together. The problem is when its split into two different disk.


Etcher is not a partitioning tool, it has no concept of partition at all.
When you flash an image on a drive, it will write the whole image at the beginning of that drive and leave the rest of the drive empty.

When you flash an OS (like in your case with Batocera), it usually do the resize itself on first boot.

From their doc I can see that on step 10 :

“Boot the Batocera drive and let it automatically expand the userdata partition (could take a few seconds or a few minutes, depending on your drive size/speed), it will reboot again once done. Don’t turn off the device during this step or you might risk data corruption!”

Note that the drive will probably be formatted as ext4 or another Linux filesystem and windows won’t be able to read/write by default

So would I have to delete the portion that is missing in a linux based system and try to convert it back to something windows can read?

I can see the partiton on my steam deck. I know steam uses a version on linux. Can you explain to me how to delete the partition using linux? I know how to do it on Windows, clueless to how to do it on Linux. Thank you

Here is what I am talking about in KDE Partioned Manager on the steam deck. I want to delete the used partion of 96.97 GBs and reclaim that space.

FIXED I used this youtube video to fix this. Have to download minipartitioning tool to fix it. Thank for all your help. It allowed me to reclaim this partition on the disk.