BalenaDash log in on a private dashboard or Keyboard input to log in manually.

i’m trying to use an existing Dashboard from a project management tool but it needs the user name and password permissions , i try to connect the keyboard to access, but the balenaDash does not seems to recognize it. i was able to connect the mouse using the command WPE_BCMRPI_CURSOR, but so far i have not found a similar command for keyboard input or a command to provide user and password permissions.
Is there a way to log in into my private dashboard using BalenaDash?

Hey @g_juan_carlos_botero welcome to the forums.

Could you let us know what device type you’re using here? I’ve just tested the setup (you can use SHOW_CURSOR = 1 to enable), and both keyboard and mouse appear to work fine. I’ve tried it on a 64-bit OS (which uses Chromium) and 32-bit Pi 3 which uses WPE and both are working OK using that configuration variable. Any basic USB keyboard should work with this setup.

Hi @chrisys and balena team,

I am using a raspberry pi 3B and with the command SHOW_CURSOR=1 the mouse works fine, but the keyboard does not. I tried 3 different keyboards to eliminate the possibility of keyboard malfunction, but still the problem persisted.

Before installing the BalenaDash I had this PI3B with raspbian and never had problems with the keyboard input. What else could I check to solve the problem?

Hi @g_juan_carlos_botero , just curious if you tried to enter text into any other site besides your private dashboard’s credentials fields? Just trying to rule out issues with that particular page through balenaDash.

Hi @alanb128. Yes, I try different pages.

Thanks for confirming that. I’ll discuss with some other team members and see what else we can suggest for you to check.

I tried plugging in a USB keyboard to a Pi 3B running balenaDash and it was unresponsive. By shutting down and cycling the power, with the keyboard connected from before power up, it then worked. (I used https://dashboard.balena-cloud.com/ as the test credential page for LAUNCH_URL) Have you tried this procedure?

@alanb128 It is works now!

I had tried to restart it from https://dashboard.balena-cloud.com/ but have not tied to shut it down from there. The times I turned it off it was de-energizing it.

Thank you very much for your support, so far I have really liked this platform and I see strong potential for future projects.

Hi @g_juan_carlos_botero,

That’s great news that it is working now. Is there anything else we can help with?

Thanks,
James.

Hi @jimsynz, No for the momento, thanks a lot.