balena ssh suddenly stopped working

Literally yesterday I was using the balena tunnel command successfully to tunnel localhost:4321 to <device-uuid>:22222.

I added my public RSA key to the Balena dashboard. Then, I ran

balena tunnel <device-uuid> -p 22222:4321

Then, in a separate terminal, I used the ssh command like so

 ssh -L 8443: -p 4321 -i /path/to/private/key <username>@

This worked very well. However, this morning when I tried to do the same thing, I get this error from the ssh cli

OpenSSH_9.0p1, LibreSSL 3.3.6
debug1: Reading configuration data /Users/bm/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 21: include /etc/ssh/ssh_config.d/* matched no files
debug1: /etc/ssh/ssh_config line 54: Applying options for *
debug2: resolve_canonicalize: hostname is address
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts' -> '/Users/bm/.ssh/known_hosts'
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts2' -> '/Users/bm/.ssh/known_hosts2'
debug1: Authenticator provider $SSH_SK_PROVIDER did not resolve; disabling
debug3: ssh_connect_direct: entering
debug1: Connecting to [] port 4321.
debug3: set_sock_tos: set socket 3 IP_TOS 0x48
debug1: connect to address port 4321: Connection refused
ssh: connect to host port 4321: Connection refused

I also tried this

balena ssh <device-uuid>
[Warn] Node.js version "21.7.2" does not satisfy requirement ">=18 <20"
[Warn] This may cause unexpected behavior.
(node:34594) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
(Use `node --trace-deprecation ...` to show where the warning was created) Permission denied (publickey).
SSH: Remote command "host <device-uuid>" exited with non-zero status code "255"

Are the SSH keys correctly configured in balenaCloud? See:
Are you accidentally using `sudo`?

but it tells me that I might have the wrong public key, which is not true since I checked that countless times. What else do I need to do to make this work?

Hello @Blaise apologizes for the long delay answering here!

Could you please confirm if this is working now on your side?