Balena Sound / writing SD card error


I triend to flash BalenaSound on an SD card today. But I’m getting an error all the time “Unexpected end of file”. Does anyone now what size the SD card should be, because I can’t find it anywhere. (I’m using a 8GB)

I also tried on another computer to flash it to a USB device (I have no card reader on that PC), and then it stops at around 780MB, without any error.

Can anyone tell me which might go wrong during the flash, I can’t find a logfile anywhere.



Firstly, I would like to ask a few questions to get some more detail:

  1. what version of etcher are you using?
  2. are you using a windows/linux/mac computer? (which one, what version)
  3. have you tried flashing a different SD card on the first computer you tried?
  4. have you tried flashing the same sd card, on the second computer?
  5. the error message that you receive, unexpected end of file, when does it show up? Is it during the flashing, or verifying stage?

In response to your questions:

  1. An 8GB sd card should be large enough to run balena sound
  2. To access the etcher logs, you can use the key sequence ctrl + shift + I , then click on the console tab


Thanks for your quick reaction. I got it fixed, after I reformatted the SD card it flashed without a problem.

But now the appliacation doesn’t seem te start ok. I don’t see any service running like in the instruction (see below)

What can be wrong here, I don’t see any error message.



hey ronald!

nice work on getting things working with etcher!

Do you see any services there at all, or is it just empty? Have you used the deploy with balena button in the instructions: Getting started - Home to create the app?