Balena OS + raspberry pi not working with Huawei dongle anymore

Hi, can you also boot without the udev rule and see if you get a network interface created? It may be an additional eth interface or even an usb interface listed with the ifconfig command. If that is created then it means it is using cdc_ether and it can be configured in a different mode. You could also attach here the entire dmesg for completeness if you are able to. Thank you

Hi!
I’m getting a similar problem as @tgirotto . I’m using Balena Cloud with RPi Zero W, hence I’m only able to use version 2.32.0+rev1 or 2.46.1+rev1.
I’ve been using Huawei E3531 for a while with success, using the following setup file (cellular):

[connection]
id=cellular
type=gsm
autoconnect=true

[gsm]
apn=onomondo

[serial]
baud=115200

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

While using the version 2.32.0+rev1 it works fine. But if I try using the newer OS version, it fails. If I connect it to a wifi and ssh onto the device, and inspect, I can see the device is detected but the state keeps “connecting”:

root@1d45855:~# mmcli -m 0   
  -----------------------------
  General  |         dbus path: /org/freedesktop/ModemManager1/Modem/0
           |         device id: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
  -----------------------------
  Hardware |      manufacturer: huawei
           |             model: E3531
           | firmware revision: 22.521.31.00.400
           |         supported: gsm-umts
           |           current: gsm-umts
           |      equipment id: 861143038644775
  -----------------------------
  System   |            device: /sys/devices/platform/soc/20980000.usb/usb1/1-1
           |           drivers: option1, cdc_ncm
           |            plugin: Huawei
           |      primary port: ttyUSB0
           |             ports: ttyUSB0 (at), ttyUSB2 (at), wwan0 (net)
  -----------------------------
  Status   |    unlock retries: sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 (10)
           |             state: connecting
           |       power state: on
           |       access tech: umts
           |    signal quality: 77% (recent)
  -----------------------------
  Modes    |         supported: allowed: 2g, 3g; preferred: none
           |                    allowed: 2g, 3g; preferred: 2g
           |                    allowed: 2g, 3g; preferred: 3g
           |                    allowed: 2g; preferred: none
           |                    allowed: 3g; preferred: none
           |           current: allowed: 2g, 3g; preferred: none
  -----------------------------
  IP       |         supported: ipv4
  -----------------------------
  3GPP     |              imei: xxxxxxxxxxxxxxx
           |       operator id: 23801
           |      registration: roaming
  -----------------------------
  SIM      |         dbus path: /org/freedesktop/ModemManager1/SIM/0
  -----------------------------
  Bearer   |         dbus path: /org/freedesktop/ModemManager1/Bearer/0

If I keep monitoring, I can see it actually cycles between “connecting” and “registered” (but only for a very short period). I also tried to enable extra current, although this wasn’t necessary before, but thios didn’t help.

Does anyone know of this issue?
Maybe it is already fixed in version =>2.47, but it has not been released for Raspberry Pi Zero.
Maybe you know, @floion? Will a new version soon be released for the RPi Zero?

Hope someone can help, since I already bought a bunch of Huawei E3531

– Oliver

Hi, as it was mentioned before, it would be helpful if you attached dmesg or journalctl -a --no-pager output after boot on a device with the modem connected and running the balenaOS version that has the problem.

Hi @roman-mazur!
I’ve added the requested logs below. Here you can also see the mentioned connecting-registered behavior modem state changed, 'registered' --> 'connecting' (reason: user-requested).

dmesg_output.log (25.7 KB) journalctl_output.log (113.8 KB)

Hope it helps

Best regards
– Oliver

Thanks for that, I’ve provided it to the devices team who should have some further information when they get a chance.

1 Like

Could you enable support access and provide me with the dashboard link please? The devices team would like to do further investigation with this setup.

Hi @CameronDiver!
I just set up the device to my WiFi and enabled support access for a week. The dashboard is https://dashboard.balena-cloud.com/devices/11ee8f0b106f1a13ff56ccfcc402edce/
The 3G dongle is connected as well.

Hi, can we attempt to update this device to a testing newer OS version? Is it running critical code at the moment or we can try to remotely update it?

Hi @floion!
Yes, feel free to update it. There no crucial functionality running on the device.

Could you also connect some antennas to the modem to check if it’s signal related?

Its not. I’ve tested with two usb modems of the same model. As soon as I change the SD card to one with balenaOS 2.32.0+rev1 it works.

If you prefer I can setup another device with balenaOS 2.32.0+rev1 and the same hardware, so you can access both?

Yes, please set-up another one with the OS version that works and send us the device link. Thanks